Unable to Reclaim Disk Space from WoW Classic Update

So I uninstalled WoW to free up disk space. And then I noticed that no new disk space had been freed up.

So then I looked it up and tried all the steps in the Blue Post from this post:

Defragged, cleaned the disk, made sure the file was deleted in my system files, deleted it again in the recycle bin, restarted several times and yet the amount of available space never changed.

When I last saw the file, WoW Classic was taking up about 200gb of space… that is space I would really like to get back. And I don’t have much else I can delete on my tiny 500gb drive.

And steam won’t let me install a certain large game until I get the space needed. Any help or advice would be appreciated. And if I figure out what to do I’ll post it here. There are other games that I still play regularly that I could delete to make way for the new game but I don’t want to delete those when I should have 200gb+ of space from deleting WoW.

For reference my C Drive is an SSD

I would really like technical support to answer this but any help is appreciated.

Update: 1 month later and the disk space has never been reclaimed and the Blue response I got here …

…unfortunately didn’t help at all.

Furthermore I would like mention that this is not a Windows issue this is a Blizzard issue. This is an issue that is well within the realm of Blizzard Tech Support needing to solve as I am not the only person with this problem. As can be seen below. This is an issue that was CAUSED by World of Warcraft. An issue that other games do not cause on Windows.

Sorry for sorta remaking the post but I still feel this is important and wanted to make an update. I would like to solve this problem for others who may come across this. I had to buy a new storage drive just to get around this problem so I could play a new game. I can now reinstall WoW on my new drive but it seems like my lost disk space will just never be reclaimed. That is a bad look.

My best guess is that you have some sort of data protection program running on your computer. Yes, it is a Windows problem. If you delete the files, it’s up to Windows to remove them from the file allocation tables, which brings me to suspect you have some sort of security software that is preventing that area from being written again

That conclusion doesn’t make sense to me, considering that WoW Classic is the only game that has ever caused me to encounter this issue. So, in my estimates, it seems far more likely it’s a WoW problem. And problems where WoW interacts poorly with Windows, is also a WoW problem. No other game has done this. Only WoW Classic. And again, I’m not the only one having this problem with WoW Classic.

I mean, is it not on Blizzard’s end to design their uninstallation program to actually do what it’s supposed to do? I feel like that is where the hiccup is. Not with windows. And even if it wasn’t this should still be an issue Blizzard should be concerned about solving.

There’s also the problem, that I being a paying customer, am having: that I can’t install retail WoW thanks to the space that WoW classic won’t relinquish.

As for security software I don’t use any other than Windows Defender and that isn’t the cause.

Yeah it sounds like you did something that screwed your permissions up. A lot of windows tweaker and debloater apps mess with settings like that. I’ve seen issues like this pop up in other games and it almost always stemmed from them using things like these or “take folder ownership” type apps that let you go into locked system folders.

The last solution you could try is to right click the battlenet icon and run as admin, that might be enough to get rid of the files finally. But overall, I agree with the blue post you linked. You borked something and it’s going to be very hard to undo, since you might not even remember what you did to break it.

1 Like

When you delete a file in Windows, it will automatically recover the space. The only way that Windows will not recover the space is if something is protecting that portion of the drive. So either all the files have been turned to read only. Or like I said earlier, even though you don’t think so, there is data protection program running. You may not have installed it but it may be left over from some antivirus that was installed at one point or another. An undelete program that was installed one pointer another. A set of tools like io bit.

World of Warcraft has no control over the deletion of files from your hard drive that is 100% controlled by windows

1 Like

I haven’t done and I don’t do anything like this. I understand computers pretty well and I’ve installed almost nothing on this computer except games (installed exclusively through steam and battlenet), my graphics driver, firefox, steam, and discord. I don’t even have VLC player on this computer lol…

Impossible. Unless its Windows Defender. I installed a clean Windows 10 OS on this PC that I built only 2 years ago. There was never any other security software besides defender which comes with Windows 10 by default

So you’re saying game software has absolutely zero to do with the uninstallation software… the uninstall program that is literally started by going through Blizzard’s battlenet app? Can you explain to me then, why no other game, except WoW Classic, causes this issue? I’ve installed and uninstalled numerous games in an effort to clear up space. Many of them comparable to WoW Classic in size… and yet only WoW Classic causes this problem. All the other games uninstalled properly and gave me back space. And through all my research, WoW is known for causing this issue. Other games rarely if ever cause this bug to happen.

You might have ran some other external companion app with WoW that messed with the folder permissions. WoW is a game known for people using external apps to manage things. Things like addon managers, TSM and so on. If what you say about your OS environment is true, it’s likely that one of them that corrupted the folder permissions.

Is your WoW on your main OS drive or is it on another drive? Also, what is your WoW install directory? If you have WoW on a different drive, you might be able to wipe all the partition data on the drive, recreate a fresh new one, format it and reinstall the game. That would 100% ensure any new files would have brand new untainted permissions.

Okay I didnt think about curse forge or TSM. Might those things prevent WoW from uninstalling properly?

Main OS drive unfortunately. How would I check my install directory if the game is uninstalled? Im not sure how to do that.

Edit: I see Blizzard’s technical support is alive and well

Having the same problem

1 Like

Hmmmm… and yet, using file explorer to navigate to the install folder and seeing if there are files there isn’t something you know how to do?

Reinstall windows to remove classic.
Keeping files option.
The account you used as the install.
Must have sub time on it to install it as well as that account should be the one to remove it. Just like ptr.
Good luck.

So I built my own computer but unless I know everything YOU know I’m a total caveman and don’t understand the basics about computers?

No, the issue is that you said you know computers pretty well, but don’t seem to know how to use the file system to determine if a file exists and is taking up space.

This is the exact same skill you would use to find a downloaded file, or a saved document on your computer, or to find a file in cloud storage. When you say you can’t do that, it tells the forum users that we can’t give you more complicated or technical instructions, because you don’t have base level knowledge.

Now, if you can find a downloaded file, then you should be able to find the install folder and see if there are files there…


Except I literally did that. Where on earth did you get that conclusion? I’m not lost in the dark here wondering if the files are taking up space… THEY ARE. THEY’RE TAKING UP SPACE DESPITE ME LITERALLY MANUALLY DELETING THEM THROUGH THE FILE SYSTEM AND CONFIRMING THAT THEY’RE DELETED. I know EXACTLY where WoW normally installs the game and I uninstalled it and then found the files and then deleted those too. Not that I should have to do any of that when a properly designed uninstallation program is supposed to do that for you. But ofc I like to be thorough so I made sure. Space is still not reclaimed.

The problem isn’t me not understanding computers the problem is you not even being able to understand what the problem is that I’m having because you’ve never had this problem before and wouldn’t know how to solve it if you did.

No one said this but you. It’s like you read what people say and then dumb it down in your head and then subconsciously strawman what they’re saying without realizing it and then proceed to pretend that that’s what they’re saying. How about you go to the general forums if all you’re going to do is come here and insinuate people are unintelligent and incapable of understanding simple computer functions.

This wasn’t me saying I don’t know how to use file explorer on windows. Literally children know how to do that. It was me pointing out that you’re judgemental and like to talk down to people

The salsman at the store said I would never fill up the 20meg hard drive. As long as I had a good supply of 5 1/4 floppy drives. I bought a box of 10…still got them; 360k single sided. My friend had some 720kb floppys. They were just 360kb with a hole punched on the other side…
We had Dos… Dir A:\wow.exe

Find wow.exe

It’s literally called “File Explorer” what are you on about?

Roughly 90% of the programs you’ve ever installed, will leave behind folders after they are uninstalled. Usually, it’s just logs, user configurations, screenshots, user saved things, etc, but sometimes it’s more. Uninstallers don’t usually just delete the whole folder blindly, they usually have a list of specific files to delete.

If WoW’s uninstaller did that, you’d lose all your WTF, Interface, screenshots and so on. So the default method they use is the CORRECT one in the eyes of almost every user that would want to keep their stuff after an uninstall.

As far as I know, reclaiming space just means that it’s consolidating content within the PAK files and deleting temporary files out of the bnet temp download directories. Most installers have a redundant system for stuff like this, so they can take up two twice the space of the installed game, while installing, and then delete the temp copies once it has verified their integrity(to prevent having to redownload whole files again), there are other reasons for it as well, but that’s beside the point.

Within the PAK files, think of them like a virtual partition. WoW divides the data up into 1gb files. In theory, you could have a PAK file that’s 1gb, but only contains a few mb of actual assets, while the rest of the PAK is zeroed out. When you reclaim space in them, it scans through to “defrag” the PAK file and remove empty space, which can shorten the overall length of the file, thus “reclaiming space.”

The three most common reasons why the installer might fail at doing these operations is:

  • Security softwares other than the default Windows Defender interfering with the operations
  • Messed up folder permissions/ownership that could be that way due to you manually messing with things or running softwares that did it for you
  • Some kind of overall systemwide messed up permissions/ownership or policies, that then sets the template of permissions/ownership for every new folder created

Lots of “debloaters” and “don’t spy on me microsoft” type apps can mess with things like permissions and ownership, which is why I asked you about it earlier in the thread. Even without running apps to automate it, tons of people will still follow the manual guides of doing things like tweaking registry settings, running some powershell commands to remove things and so on.

1 Like

I believe the op means…

The disk was a size before install, but after removing the program. The drive reports 200 MB less than that drive size. With nothing being reported on the drive in file explorer.
Like the files/folders are hidden from search, or bad sectors on the drive.
Like I said early on in the thread.
A back up or virus protection program is most likely the holder of the hidden.
This would include windows it self if you rolled back the system. Holding on to the restore files…in case you want to go back to then. One more could be the drive was in another computer and the files are bit locked to that other computer…
The windows backup partion on my C drive is 100MB.

I rather not. That’s the only thing I’m not willing to do and I shouldn’t have to do that to fix problems from WoW.

What’s weird is it seemed like the uninstaller didn’t do any of that. There was a ton of files left behind and so when I found that I went “oh okay good, I can just delete this and itll all be gone” But then it wasn’t.

Well like I said I don’t have any of these things.

I only have Windows Defender. That’s it. I’ve done everything right in regards to not having 3rd party applications that would cause this. Furthermore, I’ve gone through all the troubleshooting steps that I could find on Google (no I didn’t install 3rd party programs to do this) and nothing I could figure out reclaimed the space. So I had to buy a new storage drive to move on with my life.

That’s not what I said at all. What I said is that the space that WoW took up on my C drive (200 GB (As in GIGABYTES… as in 200 x 1000 MB)) was never cleared up despite all the files for WoW being deleted from my system.

And as of today: 12/02/23, it STILL is taking up 200gb of space despite WoW Wrath Classic being uninstalled and then reinstalled on my new 2TB drive

out of curiosity, how are you determining that wow is taking up 200gb? the game isn’t even close to that big in the first place.