[Resolved] Why is it a forum privilege to be able to ignore people?

Not sure if this is a topic for customer support, but I figured, I can ask, right?

I recently switched to a different character on these forums but I have lost the ability to ignore people.

Why is this a feature locked behind such privileges?

Are you not able to manually add them to your ignore list?

I just checked on my EU account that doesn’t have the same privileges as this account and she has the manual option available.

1 Like

This is what I get on my new toon.

Hmm, the difference could be your “basic user” vs. my alt’s “regular” status. Not sure I would have anyone that would show as “basic user”.

But it does seem like some of the settings are indeed locked behind trust level status.

Yea, I’m not at all annoyed with starting over, I expected that. But for ‘Ignore’ to be locked as a privilege…

It shouldn’t be, I’ll ask around. I know when it was first introduced it was setup with a higher requirement and I thought we had that adjusted.


…isn’t “regular” Trust Level 3?

Perhaps. I honestly have no way of checking for differences without leveling up a new character on a completely different Battle Net account.

I would have thought that my starter EU license would have been different than what I have on my NA licenses – but evidently my Trust Level is truly BNet account wide.

As an update, it does look like this feature is set behind requirements that don’t align with our desires for it. I’m not sure if something was overlooked, or if it was reset during a platform update.

We’re going to have some folks take a look at reducing the requirements or removing them.

Thanks for bringing it up :slight_smile:


Final Update -

It looks like these restrictions have been updated. Everyone should now have access to the “Ignore” system under User Preferences regardless of time spent on the forums or new vs old characters.


I still don’t seem to have access to the ignore function. :thinking:

Have you logged out of the forum and back in?

Just did, still only ‘mute’ available which does absolutely nothing.

Same thing I am seeing on this new character / new Battle Net (this is Kyzera). Only mute shows up for her as well.

Image link: https://i.imgur.com/fmgdIP5.png

1 Like

I didnt even know you could do this.

It comes in handy if someone has hidden their Forum profile as you would be unable to see their profile to select the ignore option from there. So instead, you can just manually type in the name via your options settings on your own profile page.


Ignore is now showing as an option for this new character / new Battle Net account.

Image link: https://i.imgur.com/uRznFmO.png


Thanks for confirming! Had them go back and take a second look after your previous report.

Gonna go ahead and close this topic now that it’s resolved.