Razer Naga Modifiers dont work

I have razer synapse installed and im playing retail. the modifiers like control command work when bound in razer synapse on the desktop but not in wow. I need this so I can heal.

1 Like

Try this and see if it fixes your issue.

  1. Open Terminal, found in /Applications/Utilities/.

  2. Type the following line (or copy it and paste it) into the Terminal window, then press Enter.
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

3) Quit Terminal. You should now be able to play properly.

This is the most common fix for modifier keys not working in macOS.

15 Likes

Ok so control works now but it only presses it it doesnt hold down. I also am using razer synapse so idk what problem is but I guess Ill just have to be fast (what i want to do is hold down num pad 5 whenever i want to heal myself, and release whenever i want to heal my target.)

Nevermind thats only after 1 keypress, it works well enough, thanks for the help

Have you tried using a wow add-on like healbot?

you the boss!!! it woked… it was driving me nuts

Thanks! This solved my problems

`defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES`

Does anyone know what this actually does?

NECRO. Because this worked for my M2 Mac.

This is still the fix.

having keybinds issue in beta
anyone got a fix or any idea if beta client is different?