Fixed Mac Install/Update/Initializing Stuck Hang Bug

Like many, I have been a victim of the dreaded bug for installing/launching/updating/etc. bullcrap that has happened recently with Macs.
I have the newest M3 Pro MacBook Pro with the latest update of Sonoma and can confirm this just worked for me moments ago after trying all of the other stuff I have seen around here. I hope this can help at least someone else get through this annoying crap until blizzard fixes it.

If you have not installed before on your computer, this process should work, if you already have it, do this first to remove
-First, Go to Finder, click on Applications, Move to the Trash
-Now for the cleanup of remaining files. Go to Finder, click Go in the top menu bar, click on Computer, double click on Macintosh Harddrive.
-Top right of that Finder window is a Search button, click it and type “Battle”
-In the results, you will probably see a MEGA TON of text files for logs/errors/telemetry related to You can delete them all, but what we are looking for is the folders, there may be 1 or 2. Just delete them.
-Empty the trash
-Click Apple Logo top left, Restart computer

------Start here if this is your first install and/or you completed the steps above------
-Go into settings and select the Beta version (let it install, update)
-Right click it in the dock and make sure to QUIT THE APP after it already updated and restarted itself in the Beta version.
-Open Settings
-Go to Privacy and Security Section
-Go to Full Disk Access
-Click the + and Search for Agent and
-Give both full access
-Give Relauncher full access, if it isn’t in the list then you aren’t affected. I believe it may be tied to specific versions of MacOS (This looks weird and unrelated the but this is the vital steps most miss that causes hangs)

-Go to WoW Classic (even if you don’t want it, this is vital)
-Click Install, UNCHECK THE FREAKIN BOX FOR THE LOVE OF ALL THAT IS HOLY on the Auto-Update. Again -------DO NOT AUTO UPDATE-----------
Once that box is UNCHECKED on the AUTO UPDATE
Click install.
-Let the install finish
-Go to WoW Retail and click Install
-Click Install
-Watch it install.

I have confirmed this twice on both my Wife’s iMac running whatever version is before Sonoma, and again on mine that IS running Sonoma. The only difference I found on my wife’s is that she did not have that “Relauncher” app in the Full Disk Access section and it all worked.

Sorry if this doesn’t work for you, but I felt it would be rude to not share my findings after struggling with this issue for quite some time.

Hope this works for at least a few chaps, Cheers.


This is the PC Tech Support subforum. You’ll want to post in Mac Technical Support

Bollocks, thank you. Will do.

This worked for me!

1 Like

I want to say a couple of things about this thread and problem which has dogged me for months now.

First and foremost, DUDE you are a goddam KING! Duno how you figured this out but wow, leave ur info i will gladly send u some money for fixing this problem that somehow blizzard is and was unable to. which leads me to my second point.

Blizzard, how TF are you letting known issues go on and on for over a year and not addressing them when some guy in the forums just casually comes along and fixes it? Not a good look.

I did notice the auto update seemed to be related and i tried various fixes with that but never worked, i even sold my first laptop cuz of that lol… wow man you did it! Bravo sir, thank you!!

I always wondered why i could never reproduce this issue. I haven’t trusted auto update in years, cause it’s always been broken. Guess I should have suspected it, considering I know it’s broken. It rarely honors settings or rules. in fact the background downloader/future patch setting ignores auto updates and still runs anyways.

But yeah it makes sense the failure to initialize on manual update failing, cause background process was always running and failing an auto update. The way it handles sub processes one hand doesn’t always know what other is doing.

As for why they haven’t fixed it in a year, because no one is working on it, is the short answer. :\

Did this entire procedure TO THE LETTER 4 times and it’s not working for me. I reinstalled my mac studio fresh. There was not a SINGLE residual Activision/Blizard file or directory anywhere on this system when I started. Not a single process on my machine is using any of the ports the blizzard app needs. I don’t see the kernel denying a single request from the battle net app to do anything.

First of all, I’m a software engineer at apple. Gonna put that out there right now so you know the skill level I’m working with. I know macos INTIMATELY. I’ve been using these products since my first Apple ][e in 1985. I’ve been doing this stuff for 26 years. I was a 2-digit badge number at google before this. I was a solaris and red hat kernel developer at Sun/Oracle for 11 years. I worked on the PIX firewalls at Cisco prior to that. I’m not some random kid trying to install the blizzard game they just bought with mommy’s credit card. Been playing this game since 2005.

I just spent countless hours spanning 10 days trying to install this game after re-installing my mac studio.

I’m done. This is the most ridiculous thing I have ever seen and it blows my mind this bumbling clown car joke of a studio hasn’t addressed this problem I see plaguing thousands and thousands of people. I mean just search for this issue on google. No shortage of people hitting this problem.

I’m done. Moving on. This launcher is obvious garbage written by a unqualified deverloper, sold to clients, went pear-shaped and now they can’t support it but they are still taking people’s money. Tuesday next week I’m sending a certified letter I just had an attorney draft for me demanding a refund if they can’t solve my problem. Once they deny the refund, we’re going to look at every possible legal recourse we can take. This is completely unacceptable. You can’t take people’s money for crap that doesn’t work and then ignore the issue.


you’re not wrong. My understanding of launcher is it is the most junior developers at company working on it. It’s basically the low qualification entry position. I understand it’s a far less complicated thing to build than a game engine etc but it does seem like bad practice to make the most forward facing product the lowest priority one. It absolutely stays broken long periods of time and even most simple bugs can take years to get fixed (or never be fixed) such as fake patch bug. It’s a pretty bad app.

BTW if you work at apple, I got some bugs for you that are pretty inexcusable too heh :slight_smile:


Soon as I’m not dying of the flu I’ll try this.

The bnet launcher is incredibly bugged for me, has been for at least a year (probably longer, have not been keeping track). Hangs on updates, won’t log in and freezes if I close my computer without first hard quitting it. Has difficulty logging into my account, and then will prompt authenticator because it thinks I’m doing nefarious things when I’m just trying to log in 50 times because it is broken as can be.

Ahhhhh driving me insane. There have been so many threads on this. Wish they’d get someone who was remotely qualified to spend 10 minutes fixing these issues.

Honestly believe they are going to use it as leverage to say they just don’t want to support Mac anymore.

Followed to a T and unfortunately didn’t work for me :confused: glad you found a solution that worked for you though! Crazy this hasn’t been addressed yet

Would be nice if Blizzard actually fixed this. I tried what the OP said but no luck.

Was able to get by the “initializing” while downloading issue by copying the indices folder from my PC install to World of Warcraft/Data. When I started the client, I hit continue and it downloaded 31mb and then started downloading the files. No additional permissions were needed. This was on a fresh install of Sonoma on an m1 pro.


Can confirm the same thing here on a fresh sonoma 14.3.1 install on an M1 max. No amount of anything following these threads worked, not the full disk install setups, beta launcher installed, wiping folders over and over always results in hung install.

What did work is exactly this solution. Luckily I had an old windows pc so i was able to zip up the indices folder and copy it over to the mac studio. Failed again so I repeated the hours of killing agent processes etc and just replaced the indices folder with my zip contents and relaunched. Bam. it is now downloading the game.

UPDATE: switched off beta once main game finished downloading. was able to then install classic client without any issue either.

TL;DR: they still do not have a working installer on Mac for FRESH installs and you need to go grab all the indices from a working install on another machine win or mac and transfer them to your WOW folder on the new mac to get it to install/run.

Real quality here these devs can be real proud of their work.

1 Like

Same problem here. My background is in scientific computing, but apparently that’s not a sufficiently advanced skillset to get this to work. So sick of blizzard rolling out crap. Cancelling my subscriptions.

They’ve basically abandoned Mac at this point. They don’t care. The top four or five threads about this all point out the same issue going back basically since Apple switched to ARM/Apple Silicon. They don’t want to have to code for another chip on top of having to support Metal as well as DirectX. Besides, with so many people being shoved out the door, are there very many Mac developers with Blizz anymore to fix this to begin with?

I have no confidence they care about Mac customers anymore.


After reading this thread and others am I honestly scared when I get my new Mac in a few months. By the looks of it I think I will not be reuping my sub when the time comes

I was able to get the Launcher unstuck by removing and then re-adding and Agent to the App Management settings panel.

I was able to get it to download using the indices trick. I did, however, run into Error Code: BLZBNTAGT00001389] when it finished downloading. I was able to fix this by going back into the World of Warcraft data file and making sure all 3 files were all set to Read & Write (right click the file → get info → scroll to the bottom ->check Privilege settings) .

You sir or a gentleman and a scholar. Worked like a charm. Thanks for putting in the work so we didn’t have to!

I’d also like to add my thanks to Thizzmaa. This worked for my installation of WoW too. Thank you!