DX12 Doesn't Work In 10.2

I’ve scanned and repaired. I’ve restarted my PC. I’ve shut it down. I’ve installed my latest video driver. The game hangs before the login screen unless I run the game with -d3d11. I have an AMD Radeon RX 7700 XT. I run Windows 11.

25 Likes

Pretty sure it’s only AMD cards affected. This happened with the PTR client as well.
I would hope part of the extension is because they’re trying to work on this but that’s huffing a lot of copium.
Most likely they’ll hotfix this over the next few days.

Running 6700 XT, Adrenalin 23.10.2.

P.S. I ran the PTR client perfectly fine with DX12 last night.

1 Like

10.2 causing me to have this issue as well; rx6750xt. First time I’ve ever had an issue with this card on WoW. -d3d11 necessary for client start. Servers are not yet up.

2 Likes

Same. Everything worked fine last night, all drivers up to date, keeps crashing only on WoW

Launched fine with DX11. What did you guys break, Blizz?

2 Likes

Was just coming here to post about this, same problem, works with dx11. 6650 XT. They’ll hopefully have a fix within a day.

1 Like

Same issue here. 6800 XT.

does anybody have a 7900 xtx and how does it run wow?

Ah good, they seemed to have fixed this

No servers up still, but progress

1 Like

Fixed what? I’m still crashing on DX12.

2 Likes

CPU is going to do more for WoW than a GPU. My old GTX 1070 can handle all the GPU related settings at max, but my i5-3570k couldn’t deal at all. I finally made a new build with a 7800x3d and a 7800xt and I went from 20fps in raids to 80-100.

Still broken.

100% still broken.

They’ve extended maintenance to 6pm PST.
Hopefully they can fit this in their new window.

I had the same problem. I have a AMD 6800XT and only showed white screen and never loaded. I added -d3d11 to the additional commands load option and it came right up

1 Like

This is a big problem because WoW runs a lot faster with DX12.

1 Like

FYI the PTR client that worked last night no longer works on DX12 either. Crashes like the retail client.

lol, wait, on an AMD card? no way?!!

Lol. AMD cards are legendary for having issues randomly.
My 1660ti works flawlessly.

1 Like

Nothing about my driver or card changed. This bug happened overnight on Blizzard’s end.

How do you do that? I’m having the same issue

I’m having the same issue. Also with an AMD card (6750 XT)

For anyone in need of the work-around. click on the gear icon next to ‘play’ then choose ‘game settings’ put a check mark in ‘Additional Command Line Arguments’

In the box that appears put in; -d3d11 then click done. The game should launch. But it will look less pretty until Blizzard is able to issue a fix.

4 Likes