Druid spell Typhoon disables ESC key

As of the Wrath pre-patch, there’s a really weird bug with the Druid spell “Typhoon”, where if you use it in front of a wall, or hill, or anything large/solid in front of you, it will entirely disable the ESC key. As in, pressing ESC will do absolutely nothing in any situation where it would normally function:

-opening the game menu
-closing interface windows
-canceling spell casts

All do not work. It’s like the ESC key is completely nonfunctional.

It seems to be related to the spell’s animation being cut short. If you’re too close to a wall or building or hill, some solid object large enough to “block” Typhoon, the animation glitches out and the ESC key bug happens.

Me and a few other druids have tested it, even with 0 addons enabled, the same thing happens. We’ve tried casting it against hills, walls, buildings, etc. and any time Typhoon’s animation gets cut short, the ESC key gets disabled and nothing fixes it other than completely closing and re-opening the game client.


Further testing seems to point towards it being some kind of bug with Typhoon getting interrupted / animation not finishing properly, so the game thinks you are still casting.

When the bug occurs, any other spell that I try to cast does not properly play a casting animation, my character just stands still until the cast completes, and then the “completed cast” animation plays.

So the game thinks we are still casting, hence why pressing ESC does nothing, because the game is trying to use ESC to cancel a cast…except we’re not actually casting anything. That’s my guess, anyway.

Also, hearthing or going through a portal, anything that triggers a loading screen, seems to fix it as well.


I’m having this exact same issue. Glad I’m not the only one.


I am having similar issues. In addition to the problems already described my toon won’t perform melee attacks on said mob. A simple rl doesn’t fix it either, I have to log. Very frustrating.


Same. The character doesn’t make any animations when casting either. Sometimes it also takes an additional second for the camera to turn to where my character turns. Very strange bug.

1 Like

Related to the zombie event maybe? You can typhoon in zombie form.

It also disables auto attack.

Plz fix soon

1 Like

This is also occurring to me; I’ve managed to reproduce it consistently by facing a wall and pushing directly up against it, then casting Typhoon.

For me, this was causing it to fail 100% of the time (6 attempts in a row): after that point-blank-on-wall Typhoon I could no longer right-click targets for auto attack, nor close menus/bags with ESC.

(As a side note, ESC will close the Game Menu if you open it, but won’t open the Game Menu in the first place, the hotkey for which to open it is… ESC).

As others have said, zoning/relogging fixes the issue (reloading ui does NOT fix it), and addons being enabled/disabled doesn’t seem to make a difference that I’ve been able to see.


Can confirm bug is real and still happening


oh so thats what is bugging my escape key on my druid, good to know. Also makes you unable to use your sit keybind, auto attack, and a bunch of other things probably

1 Like

I recently switched from resto to boomkin with the WOTLK pre-patch and noticed my ESC key would stop working from time to time and now I know why. Typhoon is definitely the cause, I can re-produce the bug 100% of the time.

1 Like

Im having this same issue randomly with my CTL key

1 Like

Also having this issue

Also getting this issue.

1 Like

Tried reloadui but did not help.

Still happening, pls fix :frowning:


Still not fixed :pensive: This bug is SO annoying! It also makes you unnable to cast anything while sitting.

1 Like

Exact same issue been driving me up the wall.

1 Like

This bug is still occuring for me too. Incredibly frustrating and I have to exit the game and restart every time.

Click it with your mouse.

This does not restore Escape Key functionality though

So you use the esc key just to open the main menu? It’s also useful to ‘deselect’ targets and cancel things. It’s hard to understand how frustrating this bug is.
Also with the bug you cant start any cast while sitting.