/cleartarget not functioning properly?

I’ve always been using


to target the nearest enemy. But after the dragonflight prepatch i get stuck on the previously targeted enemy whenever i use this macro.

Is there any way to solve this problem? I just want to pickpocket in peace.


I’m having the same problem! i’m real sad… since i use it in arena alot.

Does /targetenemy not work like you want without the /cleartarget? Cycles through enemies for me.

1 Like

We dont want it to cycle through enemies. When you have the clear target in it, it targets who your looking at and you can spam it as many times as you want and it still wont change targets unless you look in a different direction.

1 Like

Thanks for sharing i thought i was going crazy for a moment. Really surprised that this kind of function can get messed up this randomly.

So there is a janky way to do almost the same thing. If you go into your keybinds (targeting section) settings you can keybind target scan enemy (hold) and when you do this it works similarly to how the macro works. The issue im having with it is that there isnt a pvp option to make it where it only works on players. So it targets random pets/totems which doesnt work for me. But i definitely advise people to try it out if your a pve player.

Wow that works pretty well. Too bad i can’t put it in a macro to also cast pick pocket. I definitely see this being a great workaround for pve players out there though.

I was having this issue, I turned off ‘sticky targeting’ and it stopped the issue.

1 Like

I dont have sticky targeting on and im still having the issue.

OK! i found a another kinda janky work around! doesnt work exactly like the normal macro but it kinda does the job!

(PS: if you want it to work better in arena just add (player) to the end of the word enemy)


Thank you!!! I’m glad I’m not the only one that uses this simple macro to target nearest enemy and seen that it’s broken since the Dragonflight prepatch got released. I thought I was going crazy.

I hope this post gets visibility and this gets looked at before the release. I use this macro to target constantly, right now it’s driving my nuts not being able to do this simple macro that I’ve used since forever. I tried everything and nothing makes the macro work “exactly” how it used to. The implementation of Sticky Targeting in-game is my best guess as to what made these two commands inside a macro break.

If I manually type each command separately it works fine, but I’d rather not have to press 2 separate keys to do such action.

1 Like

seems this is a problem when one is in a group. When I’m solo my macros with clear target work, but if I’m in a group they don’t.

Any fix found for this?



I’m not attacking tho. It’s a macro for quick emotes like the Hello or Goodluck .

bumping this for visibility. this makes the game almost unplayable for me. since 09 ive used /cleartarget /targetenemy in a sap macro and nothing else ive tried resolves this issue neatly or without cycling through targets which is not what i want. it works on wrath classic but its been broken since df prepatch


/cleartarget [help][dead]

im not sure why but adding modifiers to /cleartarget seems to solve the issue. this has been working for me but i have not done extensive testing on it yet


Does this have the same effect?

/ceartarget []

after some more messing around it seems like this didnt fix the issue, it still cycles targets as if /cleartarget isnt there which ruins it for me.


no, that function seems to do nothing as well. it seems like /cleartarget is just full on broken which sucks because this macro used to be amazing for targeting casting mobs, the smart targeting would prioritize them, just face ur character towards the thing u want and scoll your mouse wheel. action targeting is cool, but it doesnt replace that

upon further testing, it seems like /cleartarget sometimes works and sometimes doesnt, even when u manually type /cleartarget in chat its completely arbitrary whether it will work or not. there was some yellow mobs in azure span on the beach (coords 10,49 this seems to be reproducible) i happened to be near where /cleartarget worked and the macro worked fine when i tried testing some things but when i flew over more inland and tried it it wouldnt work on red mobs. which leads me to believe this is some kind of bug and not an intentional change like i thought