Can't transmog into Legion artifacts anymore?

Not sure if this is working as intended (and I really hope it’s not intended) as I was able to just before reset, but it seems it’s no longer possible to transmog Legion artifacts over my weapons anymore. Tried on both my mage and my shaman as I like to use the Mage Tower appearances on them.

These aren’t the same weapon types as the Legion artifacts (both characters are currently using daggers), so I’m really hoping that these aren’t just going to be usable with the same weapon types now.

Edit: I saw a little, green loading wheel and now it works again! Thanks!

Edit 2: Okay, this is apparently NOT fixed… at least on my shaman?

Same thing happening here. I’m so sad to not see my Scythe of Elune today. I hope this is fixed.

1 Like

Same here. Super weird.

Yeah, I spoke too soon; it’s not working on my shaman at all. It worked on my mage and I just assumed it was fixed. Oops.

So, it seems the bug report forums are monitored by QA, but they don’t normally respond to the reports. Hopefully/probably this is just something that is currently being investigated.

I’m just tired of staring at that ugly mace on my priest :sob:

I may have found a way to fix the transmog issue. I actually just completed the order hall campaign on my warlock this week and it was not giving me my artifact transmog which was the reason I did the campaign in the first place. I tried logging in and out and it just wasn’t showing up anywhere. I was using a different item that was transmogged to the first appearance. But when I tried actually equipping artifact item itself, I got the pink transmog alert and got all the appearances associated with it back in my collection. I had to do the same thing with scepter of sargeras and ulthalesh and I got the pink transmog alert for them and then all the appearances were in my collection. Then I was able to actually apply the appearances to my items again and interact with them on my yak (mystic birdhat). Maybe some other people can try this and see if it works for them? Try re-equipping the artifacts to get their appearances?

1 Like

My issue (and one that still lingers ever since LEgion) is that after you apply a Legion Artifact skin on a new weapon, and even SAVE the set in the UI, sometimes, when you reopen the Transmog UI the ‘weapon’ slot shows the surrounding brightness, as if the weapon hasn’t been applied any transmog at all (while showing the weapon’s default appearance in the Character Model).

And speaking of these recent issues, are you trying to apply the Artifact’s weapons mog from the ‘Legion Artifacts’ MENU or getting their ‘pieces’ from their respective weapon type menu?

The first choice you could put, let’s say, an Elemental Shammy transmog onto a dagger, Staff, things that, for example, if you would put in ‘singular pieces’, the game wouldn’t let you.

Saw something saying this was fixed in a patch, still not fixed.

It seemed from other reports that most of them were fixed, but not ones that use offhands. Which item were you unable to transmog?

Yeah I am having this issue on my warlock. I have a staff equipped, and can not use the Skull of the Man’ari transmog as demonology.

3 Likes

Appears to still be broken, replying for visibility (I can only specifically attest to Skull of the Man’ari personally)

as a Warlock currently stuck with a staff, this really sucks and I miss my skull.

3 Likes

Still broken after reset, 2 weeks after being reported.

4 Likes

I’m having the same problem. When I’m on my Demonology spec and I try to transmog my artifact weapon the Demo Dagger and Skull it won’t take the gold and won’t transmog the item. Its really frustrating.

1 Like

you, skull of man’ari still can’t be transmogged on staffs. What’s up bizz?