Transmog broken after maintenance

Adding my voice in because not being able to use my t-mogs I worked hard for is definitely time-to-move-on-to-a-different-game territory


yea my xmog is busted as well.

1 Like

Após a manutenção quando loguei no meu personagem vi que o transmog de arma havia sido retirado, tentei reaplicar o transmog do Alunet porem não entra, quero que o erro seja corrigido.

1 Like

I logged in today, after maintenance, and my Legion Artifact transmog was removed from my appearance in all specs. It’s still an option on the transmog vendor, but clicking okay does nothing.

1 Like

Just adding my experience to the thread. On my Druid I have a polearm that I normal have transmoged into one of the Claws of Ursoc. Today that appeared to be removed. When I when to change it I could not apply the Claws to my weapon.

I attempted to transmog a random staff and that worked. I also was able to transmog to one of the Legion Artifact Weapons themselves (Scythe of Elune) in the staff category, but the Claws of Ursoc under the Legion Artifact option does not work. I have not tried any other combinations, but it seems like the items in the Legion Artifact area no longer ignore the weapon restrictions (allows fist over a polearm in my case).

1 Like

This person claims their transmog is now working; is anyone else having the problem still? I just tried with no luck.

I did see another post with a point; the trial of style was last week. Could this ending have caused the problem?

1 Like

This is just garbage, I noticed that when you go into the appearance tab, under legion artefacts, the other spec specific appearances once again say: "Requires specialisation “arcane” (as a fire mage).

Sounds like their code for keeping the weapons not spec specific any longer got borked with the new patch.

1 Like

I have the same issue. After logging in around 6pm after a good days work at home, the first thing I noticed was that my legion artifact appearance had changed back to my currently equipped weapon and shield. Because I didn’t look legit, I mounted up on the Yak to change it back to the holy paladin legion appearance with no luck. I logged out and back in and even tried heading to Oribos thinking my Yak was broken. Nope, no luck there either. I reported the bug. Hopefully it gets fixed sometime this expansion?

1 Like

I’d like to add that I am still experiencing this bug as well, and it most certainly started today–yesterday I had my dagger + offhand xmogged as Scythe of Elune, but now whenever I visit the xmogrifier I can select Scythe of Elune as an appearance, see the price, but the button to apply the mog is unresponsive. Hoping for a fix soon!

1 Like

I’m having this issue with my Druid for both the Claws of Ursoc transmogged onto a 2-hander and the Scythe of Elune transmogged onto a 2-hander. Oddly enough I have a dagger transmogged to Claws of Ursoc that’s working just fine.

1 Like

THIS IS THE FIX!!! remog your regular weapon with no enchant. then mog for legion item.

1 Like

Sorry, just tried that and it did not work for me. :frowning:

Adding my voice to this, I had my staff transmogged to Felo’melorn and logged in today and it was untransmoged and I cannot transmog it back. I can transmog it to the frost or arcane artifact.

1 Like

Why has this still not been fixed?


I am having the same issue on my Windwalker monk. I have a 2h weapon that I normally have transmogged as one of the Legion windwalker transmogs, but now I cannot apply that transmog.

1 Like

After I had been logged in for a few hours, I decided to try to transmog again. I removed the random illusion put on my one hander and then it let me transmog to my artifact weapon again. I guess it was a compilation of being logged in for awhile and removing the illusion that finally worked.

Just adding that I am experiencing this problem too. My staff was transmogged to the ele shaman hidden appearance, and I logged in to find it was no longer transmogged and it will not let me apply it again. The enchant fix did not work for me.

Bumping this thread. Druid staff that I’ve used for a couple months with Claws of Ursoc on it was reverted and no longer works.

Seems to be a legion artifact being transmogged over a different weapon type. On my druid I can’t transmog the legion staff over my 1h dagger. However in guardian spec my legion staff is working over my polearm. So not even weapon type, 1h vs 2h weapons.


Experiencing this on my guardian druid with a staff equipped and using the legion artifact fist weapons mogged.

It’s fine on balance/resto where I use a dagger/oh and use the legion artifact staff for those specs.