Can't transfer due to mail, but I don't have any mail

Try this ticket probably your best bet.

im annoyed :frowning:

Tried just doing faction or just doing server swap, neither work.
Can race change but keeping same faction.

You also can’t server transfer with a caged pet in your bags/bank.

Has your race change completed or is it still pending? You can’t start a new character service if a previous character service has not completed.

no caged pets in bags or banks or anywhere no mail no ignore list no auctions no wrapped toys absolutely nothing to stop me from transfering

Did you complete quests in plaguelands recently?

In the same boat, toon I haven’t played on in days
Put a ticket in, and now the wait…

i dont think ive ever even been in plaguelands on my dk

Hello, I am trying to move my character using the newly released Character Transfer in Classic Wow.
I keep getting an error saying that I have mail in my mailbox, and I did at first. After trying again, clearing cache, reloading to make sure i didnt have hidden mail, I keep getting the same error. Please Help.

Do you have anyone on ignore? Try clearing that list and see what you have in the mailbox

1 Like

Did you delete any letters associated with the mail? They can cause the issue as well.

Also, did you mail anything to other characters before transferring and, if so, have you removed those items from the mail?

Also, check your ignore list. You may have a hidden mail from a player you have ignored that is causing the issue.

1 Like

Are you attempting to move this character, Avengedcx? If so, it appears that you completed a quest for Greatfather Winter. I don’t wish to ruin the surprise, but he sends you the Winter Veil Disguise Kit in about 24 hours after you’ve turned in “A Smokywood Pastures’ Thank you!”.

It is that pending mail that I believe is preventing your transfer. I’m afraid there is no way to circumvent that. Once you receive the package and clear the mail, you should be able to transfer.


Well, there you go! Vrakthris to the rescue!


oh no I’m sorry, I’m attempting to move Avengedx on Fairbanks

Well great! Now you’ve ruined Christmas!

What a Grinch…


My apologies, I didn’t realize I was posting on the wrong Character, The character i’m having issues with is Avengedx on Fairbanks. I’ve checked and cleared any mail that i can see.

1 Like

I’m sorry, Avengedcx, that is the character I meant. I didn’t notice the different spelling between the two characters.


Oh, I didn’t realize he sends you a new present after the first initial one that is mailed. I guess I’ll just wait, Thank you so much for the quick reply!

1 Like

YAY! Christmas is saved!

I guess Vrakthis won’t get coal in a stocking this year after all.



Any way to confirm that I am experience something like this? I’m getting the same error.