Can't See WoW Classic


I was wanting to play the stress test for WoW Classic but it doesn’t show and I checked if i still had a subscription and I do so I don’t exactly know the problem please help. :frowning:

(Raynie) #2

There’s a drop down menu above the big PLAY button that says “version” did you check that? Make sure the “account” to the right of that is listing the account you have active game time on.


I’ve checked that multiple times but it just showed Retail and the PTR

(Nok) #4

Try selecting PTR on the launcher and then select Check for Updates to see if a classic entry shows up. You might also want to restart the launcher after checking for updates.

Alternatively, changing your password and restarting the launcher tends to clear up a lot of launcher issues.

(Kozzae) #5


I tried doing all those step and none of them seem to have worked guess im missing out yet another classic testing


Just to doublecheck, you are looking under the Live section. It should look similar to this:



I have and my only option is just PTR: World of Warcraft and Battle for Azeroth and nothing else


I also have something similar. I can see it in the In Development part, which I can’t access, but not in live. I still have 11 days of game time left.

I can’t post the picture so it’s kinda like this:

In Development
PTR: World of Warcraft
Beta: World of Warcraft Classic

[My account] (US) Battle for Azeroth
WoW 1 (US) World of Warcraft


At this point, this is probably something better suited for tech support, but try resetting your launcher files.


I tried everything in the article and nothing has worked so far. It’s still showing the same thing as I’ve said above.


I checked thier like 10 times


I bought a subscription to just to test wow classic as i have been eagerly awaiting and have yet to be able to login World Server Down every time money well spent…

(Perl) #15

You want Tech Support not CS.

Also, remember that it’s a test. That’s the point of this. It’s not early access to Classic.

(Nok) #16

Then you are stress testing as intended.
The purpose of the test was to stress the facilities… not to let you play for a day.


Awesome stress test just login and look at the character creation screen… fail to see how that gives much input. Level 15 character limit was the draw.


I can’t even download the client. It would be really nice if I could even start the game. It would be even better if someone would respond

(Nok) #19

Did you bother to read the 10th post in this thread from Vrak?

(Perl) #20

You clearly don’t understand what the purpose of a “stress” test is. Literally it’s to push the servers to the limits. We’ve seen that happening tonight. That’s literally the point.

For issues with downloading, you’ll want Tech Support.

(Rufflebottom) #21

Then you both will want to post in the Classic forum. The Stress Test is run by the Devs. Customer Support does not have anything to do with the testing environment (PTR, Beta, Stress Test).

Post here in one of the current threads about the Stress Test: