Can't Pick Up Legends of Mechagon Quest (Horde) -- (Still Broken After 9/6/23 Hotfix) Please Help

My friend and I have been trying to specifically unlock Mechagon for a while now, and, as of today, we did everything. Every requirement. Every prerequisite quest. Every reputation requirement. We did every known step. We have followed this guide - - so closely, that there’s no way I missed a step. Today was the day we finally got every single thing done leading up to the point of picking up the quest, Legends of Mechagon, including, ofc, picking up AND turning in Rumors of Mechagon to Gazlowe to even be able to pick up Legends of Mechagon in the first place.

Yet, I can’t pick it up. There is simply NO quest available to be picked up from Gazlowe. I have now tried this on multiple characters, and I can’t do it on any of them. However, my friend, who I did every step with, can pick up the quest. There should be no difference here since we did everything together. She even tried to share Legends of Mechagon with me, and it says I’m not eligible to pick up the quest. But, that doesn’t make ANY sense… because, we should pretty much have the same exact progress since we did it all together.

So I checked wowhead and saw a blue post. This blue post to be exact: Problem with Mechagon (PTR ignored?)

And, it seems that, Blizzard thinks they have fixed this. Soooo, then why can’t I even pick up the quest? Why is it my friend, who did every step I did, can pick it up? But I can’t? I mean, I’d love to post in that thread to tell that blue that they seem to have NOT fixed it, but since my text ain’t in fancy yellow, I can’t do that. So maybe someone here can help with this thread? Cause I’m out ideas. My friend is out of ideas. Simply don’t know what else to do, or what I could have done wrong. The only logical solution seems to be that this is a bug but… Blizzard over here saying they “fixed” it. So what’s going on here?

Pretty close to unsubbing after all that work, TBH… :confused:

90% of the times theres something you missed weather its missing a step not being high enough of a lvl not having low level tracking on id also get ur friend to post here and a blue. Can take a look at it in the morning.

Your posting character does not show to have unlocked Nazjatar world quests yet.

If it is a different character, please provide their name-realm.


Ok well, I’m level 70? And I have others as well, who are also level 60-70. So. Yeah, don’t know what to tell you. But I did every step. I read the guide about 300 times. My friend and I never did anything seperate, so. Yeah. Don’t know what to tell you but. I’m about to unsub if I can’t even access an entire portion of the game for… what… the rest of time? Hahah. I don’t like playing a game I’m completely locked out of certain content for because of a problem that suspiciously pops up right after Blizzard makes a post about allegedly “fixing” the EXACT quest I cannot pick up. Don’t you think that’s a little sus?

There’s no other step once you unlock Nazjatar World Quests and are able to accept Rumors of Mechagon. This is according to the Wowhead guide linked on the support article on this site and multiple comments. OP completed those steps. But the NPC has no quest.

1 Like

Perhaps I am missing it, but where is the Blizzard post?

That second link in your post is the same as the first one you linked.

Batdragøn level 70 - Moonguard
Elfinborn level 61 - Emerald Dream

Elfinborn is actually a character I played in BFA. Got most of the reqs done back then I guess. All BFA rep is at least friendly on her.

Sorry. Not sure how that happened. Should be fixed now.

Stupid question are u trying to unlock it on those toons or this one.

I did both, so. Doesn’t really matter I think. And no, not Nightforge. Don’t even think I can do that on her.

Per the same thread you linked, Mechagon is now 10-60 scaling, it seems.

Can confirm Rumors was completed, so the next thing I’m curious about is which version of Gazlowe you’re interacting with for this quest? Needs to be the one in Tiragarde, if I recall.

Beyond that, the ideal conclusion is that it is still bugged for some people and zero malicious intent is afoot.

Well, allegedly, Gazlow gives you Legends of Mechagon right after turning in rumors? That is where my friend picked up the quest, right after she turned in rumors with me. I did not receive any follow up quest whatsoever after turning in rumors on both characters.

She even tried to share the quest with me. And it says I’m not eligible for it to be shared with me. Which was the scariest part because we did every step together, and I ran out of leads after that.

Have you spoken to Gazlowe in Dazar’alor? He should be near the Great Seal, just down past the flight master.

Yes lol… As I said many times before, I have turned in the pre-requisite. No quest is available to be picked up from Gazlowe after that. On any of my characters.

I wonder if it is due to some sort of phasing issue for you in Dazar’alor. Your character ( Batdragøn ) has not fully completed the opening quest line for Zuldazar.

You completed Speaker of the Horde (which established the Embassy) but you haven’t spoken to Talanji again or to King Rastakhan yet.

Does Talanji have a quest for you inside the Great Seal?

I mean, you can wonder about it. But it shouldn’t matter. I already did all of that on Elfinborn. Who, as stated before, also cannot pick up the quest. Also, as previously stated, my friend was able to pick up the quest. We did every step together. However, if you must know, I did suspect phasing to be a problem. So I did everything I could without signing up for 2 months of dying from boredom of doing the entire troll zone questline. AGAIN. No thanks.

Perhaps when the staff gets back in the morning, one of our SFAs can take a peek into things. They’re not in office 24/7, but are usually good about trying to see what the issue may be. And if they’re unable to see with their toolkit, they can then try and advise you in the best way to proceed. Even when hotfixes go out, sometimes it may take a bit for it to run through the systems. It may simply be that it’s still in the process of stretching itself out to all the accounts and whatnot. Or if it’s a missed quest or phasing from something else, hopefully one of the SFAs can see that and get you pointed in the proper direction.

I’m sorry it’s not an immediate response and fix for right this moment though.


Looks like this was just patched via a hotfix!

Uhhh, looks more like it didn’t, because I got excited from your comment and just checked bnet, only to not see an update available. So, you must be talking about earlier “hotfix”? From like. 12 hours ago? If you read my posts fully, that should fill you in to the situation here. Lookin’ kinda grim I guess.

Except this. Kinda gives me some hope. Thank you for being the only person to give even a little bit of it to me here hahah, and I hope you’re right! Because I don’t mind waiting for another hotfix tomorrow or something, just as long as I have some hope. I haven’t had the best experiences with Blizzard support. The automated kind, that really doesn’t provide a whole lot of hope.

P.S. Changed the title to reflect that this is still potentially broken after today’s update. Just to try and reduce confusion from people not reading past the title.

100% that can do it. Not doing that intro questline causes all kinds of phasing issues.

LOL. Already did it. On Elfinborn. Still can’t get quest.

It’s almost like people aren’t reading the part where I said I did this on two different characters, I don’t know.

Besides that, I can’t even find the quest anymore on Batdragon. Must have already started it in a mad scramble for power to solve this stupid problem, to no avail ofc.