Account locked - Need help

Account locked for the past 14 hours.

It usually depends on why it was locked, most of the time just changing your password should unlock it?

You can get there by using the support link on top of the page.

2 Likes

I’ve tried everything. I can’t change my password because the account is locked.

You will need to contact them directly, the forums are not a bypass to the support system sadly. You should be able to contact them, even if you can’t login. There should be a bypass to the authentication page, but be prepared to give a digital copy of your id.

1 Like

Ok. Thank you.

1 Like

I’m not entirely certain what you mean, Custard. You might not be able to change your password, but you should be able to reset it. You should be able to go here.

Click on “I don’t know my password”. You’ll be prompted to enter the email address for the account. Once you do that a code will be sent to that email and you just need to enter that code on the page you are directed to.

Once you do that you’ll be prompted to update your password.

Are you not able to do any of that?

1 Like

Any time i try to reset my password I get a message saying,

" Too many attempts.

You can’t access this page right now. Please try again later."

This has been ongoing for over 14 hours now.

1 Like

Unfortunately, if that is the case you’ll need to submit a ticket so that our staff can help. You should be able to submit a ticket here.

1 Like

I submitted a ticket with my photo ID but now I don’t have any way to review the status of the ticket. I am locked out of my account. It would be a lot easier if I could get a text message to my phone or an e-mail to reset my password but I am locked out of even doing that.

It looks like you have SMS Protect set up, do you get the same error with the first link I provided if you enter that phone number?

1 Like

Yes. If I enter my e-mail or phone number I get that error.

Also on the “Contact us” page I am able to enter my phone number. But I never get a text with the code to input. The weird thing is that I am able to get my e-mail account texted to myself (to make sure the e-mail wasn’t changed somehow) - but for some reason I never get a text with the 6 digit verification code. Essentially I can confirm that both my e-mail and phone number are what they are supposed to be; i.e., they weren’t changed.

Just tested the SMS code system by attempting to remove my authenticator – got the text without a problem.

@Custard, is it possible your phone has the number blocked? For me, it comes from 732873, but I don’t know if that varies from person to person or cell carrier to cell carrier.

1 Like

Yeah, I don’t know what is wrong. I am still able to get text messages from Blizzard in some capacity. There is a button called “I don’t know my e-mail address”. When I click it, it texts me my e-mail address just fine. For some reason I just can’t get a text to go through with the verification code.

And when I try to send the verification code to my e-mail address it tells me that I’ve done it too many times and to try again. Even though I’ve been trying for going on 16 hours now.

How often have you been trying? Usually it wants about an hour of stop-bothering-me time before it’ll give up on the ‘Too Many Attempts’ messaging. Over 16 hours, it seems unlikely you’d have failed to give it that much time between attempts, but I figured I’d ask in order to make sure.

Only other thing I can think of would be some kind of issue with the device itself. Have you tried restarting your phone and reattempting to receive a code?

I went to sleep for 6 hours and also left my house for a good 4 or 5 hours earlier today. So there has been a good chunk of time where I didn’t mess with it.

What about restarting the device? If you haven’t done that recently, give it a shot and retry?

I restarted my phone but now I can’t even input my # into the webpage. I get the “too many attempts” message just by clicking on an option now.

That’s… weird. Maybe it’s a caching issue? Try a different browser, or an incognito window, maybe?

Way ahead of you. By the way, thank you for your help. This is hella frustrating and I appreciate you trying to help me.

Hey, no problem. I’m stuck at work anyway, and it’s really not much more than friendly advice.

Worst-case scenario, a GM should be able to at least get you access to your account by removing SMS Protect and bypassing whatever security lock this may be, but hopefully we can make some headway here.

Did the different browser/incognito thing help at all?