9.2.5 Self Cast Key Breaking Reticle & Mouseover Macro Logic

As of 9.2.5 reticle spells appear to be impacted by the Self Cast Key if Auto Self Cast is enabled. This is fine. The problem is it’s automatically being applied to macros AND handling the macro logic differently than spells taken from the spellbook.


If you cast a reticle spell macro while holding the Self Cast Key modifier, even if no [mod:SELFCAST] condition is coded, it automatically tries to cast it at your target’s location.
eg.

/cast Door of Shadows

If you self-cast the spellbook version, it automatically tries to cast it at the player’s location.

This behavior is consistent regardless of which modifer the Self Cast Key is set to, so long as there’s no keybind conflict.


This is super janky for those of us who use macros heavily:
a) because we’re used to manually coding our self cast conditions ie [mod:SELFCAST,@player] or [mod:alt,@player]
b) because the behavior is different than the spellbook version
c) it introduces functionality not previously available to, or intended for, reticle spells, essentially the ability to cast [@target]. Think of being able to instantly drop perfect frost traps etc. on your opponents in pvp.

More information:

4 Likes

You can use [@none] as a workaround while we wait for a fix.

[edit]
Blizz broke this, see below.

Just learned this bug works with any @unit including chained logic.

ie. [@mouseover,help,nodead] [] SPELL will cast @mouseover if friendly or target otherwise. Allowing you to automatically drop reticle spells on raid members by mousing over their frames.

In an attempt to fix the bug Blizzard has now introduced a new issue where it’s impossible to display the reticle for placement, or cast the spell in any way other than @player, if that key combination includes the Self Cast Key modifier.

Macros that map to the Self Cast Key modifier now automatically cast @player, even if you’ve specified @cursor.

/cast SPELL -- casts @player while holding the self cast modifier key
/cast [mod:SELFCAST] SPELL -- casts @player
/cast [mod:SELFCAST,@cursor] SPELL -- casts @player

Even if you attempt force it to display the reticle by using @none it casts @player.

/cast [mod:SELFCAST,@none] SPELL

Please just roll back the macro logic code to the pre-9.2.5 version.

4 Likes

Breaking so much stuff for no reason. Hey how about letting us use @target for reticles? I sure would love to know their reasoning for not allowing it.

The original root cause is that they added the ability to self-cast the spellbook versions in 9.2.5. I assume the macro stuff was originally just collateral.

Frustratingly, I have to add “so it’s not just me” here, though it does help me feel better – spent a while troubleshooting this last night and knowing it’s nothing I did wrong (I figured it wasn’t; I hadn’t changed a thing) helps a lot.

I used to work in IT, and troubleshooting is mind-numblingly boring, especially when it becomes apparent that a problem is with a system I don’t have control of. I’m guessing this one is a regression bug caused by some other code tweak, and hopefully it will be fixed.

Can confirm that the [@none] workaround does not work for me (yay, failed fixes), at least not with Healing Rain and my Clique macro:

#showtooltip Healing Rain
/cleartarget
/cast Healing Rain

This previously would clear my target (I use a focus-preferring Interrupt macro to work around needing to do that; I didn’t know about @none) and the reticle would appear for me to place Healing Rain on my party/raid.

Now, Healing Rain appears on my location, and I am not always where the rest of the raid is (some bosses require melee to stand in a different spot, and often they need the most healing, or healers/ranged have different mechanics to deal with).

I have had to put a button on my action bar to enable me to cast Healing Rain and Deluge with use of the reticle, but it’s by far not optimal since the spells no longer work properly with Clique while the rest of my healing spells work fine.

Aren’t bugs fun?

3 Likes

This is definitely broken and not merely “changed” now.

I first noticed this with Heroic Leap, but at least on Warriors it’s ok to just set the Auto Self Cast key to “None”. Less so on Venthyr Priests…

Auto Self Cast should not be equivalent to [@player], and especially not override actual other conditionals in macros.
They way I understand it, [@player] was introduced to execute a Self Cast of abilities aimed at units, without having to use a specific Self Cast key, and also to place ground-targetted abilities on top of yourself. That is not Auto Self Cast’s territory.

1 Like

Quickest way to restore proper macro functionality is to set the Interface > Combat > Self Cast Key to None. That said, doing so kills your ability to force non-macros to self-cast.

I remarked in the linked thread about this, but to put it here also: that’s what I ended up doing to fix it. ElvUI moves the self-cast options out of the default game option UI and into the ElvUI settings, but once the self-cast key is set to NONE (and I removed all the other modifiers like auto focus/target casting), everything started working again for me.

Anything I want to always self-cast is already a macro so everything’s working again the way I like it. I still think it’s odd that if you put /cast foo with no arguments in a macro, it’ll cast on you no matter what. But maybe it’s a coincidence because I had the alt key as part of the key shortcuts for both healing rain and deluge and never needed to remove the self-cast modifier before.

3 Likes

That’s the origin of the bug basically. Prior to 9.2.5 you couldn’t Self Cast reticle spells without using a macro. In 9.2.5 they made it so you could and, in doing so, introduced the original bug. Then they took a ham-fisted approach to fixing the original bug by forcing macros to cast like the spellbook versions.

Assumptions about targeting should never be made for macros; the only exception to this, which doesn’t apply to reticle spells, is the default casting behavior with Auto Self Casting enabled. Again, doesn’t apply to reticle spells because their default behavior should be to display the reticle regardless of Auto Self Casting.

Blizzard needs to restore reticle macro functionality to the pre-9.2.5 version.

2 Likes

I got around this by setting the self-cast modifier to ‘none’ in blizz’s options, but letting Bartender handle the self-cast modifier in its addon settings.

That said, this really needs to be fixed before people begin relying on this new behavior.

1 Like

Came across this one that I just don’t understand. I use this for my distance totems. Weird thing is the mod:alt will drop the totem at my feet, and mod:ctrl just won’t cast anything at all but no mods and mod:shift work just fine.

#showtooltip
/cast [@cursor, mod:alt] Earthbind Totem; [@cursor,mod:shift] Capacitor Totem; [spec:3,@cursor] Spirit Link Totem; [@cursor] Earthbind Totem

That’s the issue reported here. The best workaround atm is to disable your Self Cast Key in the Interface options, to squash the bug, then set your self cast key in a barmod like Bartender to what it should be.

might be in conflict with your pet bar keybinds. keybinds take priority over macro modifiers so you’ll need to unbind any conflicts. By default: CTRL 1-6 = Pet Bar, SHIFT 1-6 = Action Page

Still an issue as of 10.0.2 (45569)

Can you go into further explaination? This new change has broken my game for my Rsham.

I change blizz ui to none and uncheck self-cast box. Go into bartender addon and self-cast alt option enabled but it just changes the blizz option ui options and results in no change. Still can’t target with reticle spells.

The way I’ve gotten it to work is by changing

  1. Interface > Combat > Self Cast Key to None
  2. Then setting /bt4 > Bars > Self-Cast Modifier to ALT

As of pre-patch this bug is now affecting @mouseover macros in addition to reticle macros.