Unable to download from website - Network Failed error

I can’t even download the game it keeps saying failed-network error but my wifi is working fine.

I am getting the same error

can’t download anything from blizzard even the blizzard app itself

1 Like

Hey there,

I moved these reports to a new thread since it’s a different issue. Typically when I see the “Failed-Network” or similar errors when downloading from the website, it is related to either security or stability causing the download to not complete.

I normally recommend a power cycle of both the computer and networking devices. For the computer, shut it down safely and leave it unplugged for 20+ minutes. For the network devices just unplug them for 20+ minutes. Power on the network first and allow 10 minutes for it to set up before turning the computer back on.

I have also seen the error caused by security software such as little snitch (mac) or noscript (pc). Any similar security software can cause this error so disabling it temporarily to verify if it’s related may be a good idea.

Hope the info helps! Let us know if this works for you or if the problem persists.

I’m having the same issue, I have no security software running. I’m on the latest MacOs on a 2017 Macbook pro.

Did a speed test and I’m getting 100mbs up/down 9s ping. No issues.

Mac User, I was able to download RoC… but I get the Network Error attempting to download Frozen Throne and/or Reforged.

1 Like

I downloaded and installed a mac VPN (Hotspot Shield), I was able to download no problem after that - which is super weird to be honest.

1 Like

Unable to download the game even after restarting and resetting everything.

Checked my speeds which are good. 933.83/Mbps Download and 934.65/Mbps Upload. Only blizzard is having issues for me at times getting Blizzard agent is asleep.

same here. mac user on 10.14.6, successfully able to download WoW but get Network Error trying to download reforged. I even tried downloading the battle net app for the app to update reforged but it keeps crashing. in all honesty this is bullsh!t :upside_down_face:.

Hey all,

If the steps above don’t work, that usually means there’s a firewall or ISP issue. The other things I’d try would be:

  1. Configuring your firewall to allow signed software
  2. Making sure you disable any proxy settings you’re running
  3. If all else fails, connect to a mobile hotspot/tether, or a VPN client. You only need to do this for long enough to download the installer file.

Once you get battle.net installed on your PC, the application itself should work fine and install the rest. If you continue to have issues after you install the battle.net application, you want to start your own thread or contact support.

A post was split to a new topic: Buroji - Failed: Network Error

I am getting the same error,can’t download anything from blizzard even the blizzard app itself , just now bought the wc3 and keep failed download, so hopeless this game.

didn’t work for this, already trying 1 hour still keep download failed, waste for my money to buy this game, keep download failed, use other channel (internet explorer to download also failed!

I restarted, I unplugged the wifi and replugged, and I cannot download the WC3 Setup. It says failed network error. Isn’t there an easier way to get this early 2000s game? I bought this and I can’t play it.

If even your old games don’t work, what does that say about your new games? I’m on a on a MaC running Catalina 10.15. Do I need a Windows 2000?