Cannot install game

I’m having the same issue. It says I purchased it and can’t install yet. I probably wasn’t going to play tonight but I wanted to start the download at least.

1 Like

Do yourself a favor and just request a refund. Garbage launch.

“game cannot be installed yet”

-yes ive payed for the game…
-opened and closed bliz app to check for update…nada
-uninstalled beta in case that was a problem…nope

Howdy!

It’s likely that the Blizzard app hasn’t updated yet to the release. I would recommend trying the following steps to force it to update. Note: Make sure you already tried closing the Blizzard app fully -> Restarting the PC and logging back in before doing these steps:

  • Exit the Blizzard app -> Clear the cache files.
  • Reset your Blizzard account password to reset the server side cache.
    -> Log back into the Blizzard app to retest.

Thank you.

Did both, still no change.

Thanks, I didn’t ask for your opinion though. Looks like it started downloading actually so I’m good.

2 Likes

I am having the same issue. I am suspecting that this is very much a server side issue, as I have two updates, one for SCII and one for Diable III, that won’t download. Then I get this error code: BLZBNTAGT000008A4(FYI, as a former tech support guy, now a backend server break/fix tech, the more info you can give, the better. Just saying “It won’t work” isn’t enough. behaviors, error codes, this is what really helps diagnose a problem)

1 Like

not getting any errors just the install button is greyed out so I can click it

Well, if it is feasible for you, trying (re)installing hearthstone, see if you get any errors

3 posts were split to a new topic: Unable to download from website - Network Failed error

I also cannot download the game after I’ve purchased it. Initially, I had a blanked out ‘Install’ button next to it saying “You’ve purchased this game” and below that Release date: 1/29/2020.

That is now gone and now when I click into WC3 tab on the battle.net launcher…the page is blank, just the background.

BLIZZARD SOS FFS. I’ve updated battle.net.

I can’t download the game. This is bogus, it indicates the launch for dec 2019 then for jan 28 and still not able to download anything.

Is your Blizzard app updated to the most recent version, got prompted with an update for it, re-logged in and now its showing the option to install.

“game cannot be installed yet” still…

sucks to see friends playing the game and I cannot even install lol. I wish they had to suffer like me! >:(

It does not do anything to update the app, as of yet. Wagering a common sense guess, their authentication servers authenticate more than just account sign-ons, I.E. (to keep the explanation simple) they are also used to verify that the download requests are legitimate and that the account has a valid license to download and launch the game

prepaid 10 days ago for WCIII reforged…logging in tonight for a few min to start the download and all I can see is the battle.net client but it wants me to pay for it again. where do I get the link to download what I paid for already? I’m logged on and can see my account settings - but nothing beyond my transaction ID from 10 days ago.

I managed to fix the issue by manually downloading the game here: https://www.blizzard.com/en-us/download/

This triggers the blizzard agent update and lets you download the game.

Good luck

I pre-purchased the game over a year ago.
How do i even find the option to install the game?
Yes it keeps telling me I already have this game in the shop. I just don’t have it installed.

I was running WC3 fine yesterday. Since the patch everything screwed up. How do I get back running? Where is the install option?

Typically when I see the app suggesting the game is not released yet, the device’s date and time settings are not correct. I suggest opening date and time settings to check (Windows / Mac)