Patch 1.23.5 Notes

No man, this is not working neither, total disappointment for this managers ruining games.

1 Like

WE HAVE TO COMPLAIN ABOUT IT, I dont know how many people can not play but they just do not care about fixing this.


Hello this new version is not working for everyone, could you check what is wrong with and why crashes all the time OSX High Sierra 10.13.6. I HAVE TO TURN MY COMPUTER OFF EVERY TIME BECAUSE OF IT AND THAT MAY CAUSE IT DAMAGE. SO PLEASE FIX IT OR GAVE US THE OLD PATCH BACK, WE CAN NOT PLAY!

1 Like

I still have crashes that started a couple weeks ago, and are not fixed with the latest update

1 Like

Well, Since the post forums doesn’t gave any solutions, I made a ticket complaining about the big problems that the current patch gave us and they respond in the same way as the forum… They doesn’t know what happens (obviously), and neither they give me a solution.
I mean this is nearly “a robbery”, so if u don’t “return” my SC:R, then at least refund my money.
Because i’m patient i’ll wait for tech support for only this more week, that would be 16 days of impediment for using “my game”. If there are no news, i’ll let everybody knows about this big issue.


I do not want to defend Blizzard as in any case rolling out a patch which doesn’t work for multiple users is a big issue BUT. At least this time they gave us the chance to test it out in PTR (public test realm). So if any of you had taken the time (~15mins) to test it you could have prevented this problem.
(If this is still not the change that was in PTR, don’t mind me :slight_smile: but I think it is as the menus are so much better now just like when I tested some weeks ago in PTR)
Although to be perfectly honest they should have made some news about it in the launcher not just here on the forum. (not sure they didn’t but i don’t think so)

I don’t want to flag your comment, so i have to respond to it because i consider it inadequate. Why use the word “if” in a serious conversation," post"?, life isn’t about “if”. Its about “did, do and done”. “If” i had study, i would be a president, “if” i was a computer fan, then i would be a computer worker, “if” i didn’t got up so late i wouldn’t got fired… So “if we would tested the patch, we would be fine”. Thats obviously correct, as well as every “if” sentence. So i warn you about stop using the world “if” in a formal sentence, because it just divert from the important part of the conversation.
Regards, ZarpaZaina.

1 Like

the game still crashes my whole computer when I Start it. Last patch seems not to help.

btw. I’m not a Mac User
Ah and Sinclair my man, I tested it on PTR once and it didn’t crashed there.


I’m having that problem on all Blizzard games (Heroes Of The Storm, StarCraft 2…) ah haven’t tested the latest SC Remastered… For some time I thought it was because of the Lutris version I’m using to run everything on Linux, but still…

Ah… I just don’t see the issue in SC remastered right now.
I don’t know why. Maybe I should try… ah hell, I’m running out of disk space…

Ahh that sounds pretty bad then. :frowning: I hope they solve it soon!

If your mac is plugged in, it should use the 555X card. In addition, I tried only enabling high-graphics mode (meaning no battery saver) and it did not help. For fun, I tried to intentionally use the integrated graphics and it still crashed at the title screen before the game loaded but in a slightly different way. It’s just broken for some combination of High Sierra and these video cards.

7-14-2020 at 10:27 PM - PDT


Thank you for the info, BUT, I DON’T have a 555X…

My System is a Custom Built Hackintosh Desktop. Profile: iMac 18,3 - Retina 5K 27" - Mid-2017. Built December 27, 2018.


i7 7700K @4.2GHz
Gigabyte GA-H270-HD3 MOBO
CoolerMaster Hyper212EVO
32GB Corsair Vengeance LPX DDR4 2400MHz RAM
One Samsung 860 Pro SATA/VNAND 1TB SSD - MacOS High Sierra, (APFS)
One Samsung 860 Pro SATA/VNAND 1TB SSD - Win 7 Pro x64
One Mac Flashed PNY NVIDIA GTX-970 4GB Card - NVIDIA Web Driver 387.
Integrated Intel HD-630 - DISABLED in BIOS, PERMANENTLY. (Also means, NO HEVC.)
[EDIT 4:] One Western Digital Black 2TB SATA Drive, (HFS+) - 1 Partition: Time Machine - 1TB, 1 Partition Games - 1TB
MacOS High Sierra - (17G13035)

(MORE, but unnecessary to go through…)

I think you have me confused with another MacOS User. [EDIT:] (You’re thinking about Vinci.)

10:42 PM - PDT - [EDIT 2:] My System IS working fine with the Latest (8589) Blizzard SC:R Patch.

10:45 PM - PDT - [EDIT 3:] I also run SC:R ONLY in 64-Bit mode.


7-16-2020 at 6:47 AM - PDT

[Update on Hackintosh - Andromeda:]

Just Updated to MacOS Security Update 2020-004 - (17G14019).

Also Updated to NVIDIA Web Driver 387. for the Mac Flashed GTX-970 4GB Card.


1.23.5 is the worst, because the screen on my Windows 10 HP Touchscreen Pavillion Intel Phantom Laptop keep freezing on black, and the In-Game graphics and Video is lagging out and going slow when I move the map and my units. So I feel your pain, ByFastesT.

We want 2 vs 2 Rank Ladder pls!!!


1.23.5. It’s the worst, because the screen starts in blackness, in-game speed has slowed down, and the map terrain and unit movement has been slowed down, and the game is lagging out and acting out. This new patch is the worst. Besides, I don’t even have Windows DX11 or DX12, or even a MacOS Metal. A laptop I have is Windows 10 HP Pavilion Intel Inside Pentium Touchscreen Laptop. My apologies but I have to update my laptop.

We’ve just released Hotfix Patch which addresses the following:

  • Additional crash fixes
  • macOS systems that do not support Metal, will fall back to OpenGL

please just roll back the patches from 3 patches ago. It was working perfectly without frame rate issues but now it’s just unbearable. Frame rate picks up when I move the map to an outer area (fogged area) but when I return to the resource gathering area, its as if the game speed is @ ‘slowest’. I hope you guys can fix this , thanks!


What about 2vs2 ranked. Can u answer something.

1 Like

Are you guys looking into the broken replay issue at all? I’ve been bringing this up constantly and asking about it for about a year now and I’d really appreciate some word on whether it’s being addressed, or if you plan to address it at all. It looks to me as though that issue is NOT being looked into and that no one at Blizzard cares about it. Obviously, I hope that this isn’t the case, but you guys have had an entire year and a bit, so that’s the logical conclusion.

Today patch still take about 5-10 minutes to launch the game…