Laggy Menu with application crashes

Hello dear Blizzard Tech support,

recently I am experiencing a heavy lag in the game menus and UIs. It appears like some connection is blocked between my client and the server as everytime I start the game the game tells me that the “Download failed.” and loading any serverside information is always causing the lag. If I want to join a custom game lobby the game list is VERY laggy and every time I scroll the screen freezes for like 2-3 seconds. If I want to take a look on a player profile the game even crashes after freezing (it never finishes loading).

Thus far I have tried following fixes:

  • Scanned the game for errors (nothing found)
  • Reinstalled the game
  • Reinstalled newest grapics card driver (GTX 1060)
  • Reinstated the Port Forwarding from 6112 to 6119 on both TCP and UDP protocols

Nothing helped. After reinstallation the game asked me twice if I want to white-list the game, which I have accepted both times.

Ingame there is no lag at all (other than the normal ingame lag, but thats distinguishably different from the menu/UI lag).

If you need a video from this problem, I can provide one. Just tell me so and I will upload a video of this problem to Youtube.

Here is a DxDiag of my system, while running Starcraft:

Thank you for your help. And I am happy to provide more information if needed!


The same problem in my topic -

I have no idea how to fix it.

1 Like

Please give an answer :frowning: This is really frustrating :frowning:

So I was 2 weeks away and this problem still persists :slight_smile:

I cannot access profiles and the game is laggy af and this will stay like this?

Cool story Blizzard!

Hey chrisolo,

This forum is primarily for player to player help. SFAs sometimes reply, but it’s not guaranteed.

To get immediate 1 on 1 assistance you want to use the support ticket system. You can use this ticket to get started. You can also link back to this thread in the ticket for reference.

I finally could resolve my problem with the help of the technical support.

I had a faulty Registry. I fixed it with the registry cleanup tool “AVG TuneUp”.

Just wanted to follow up on my problem with a solution :slight_smile:

Thank you tech support :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.