SCM Draft failing to launch (solved)

I have recently re-downloaded the game. Wanted to make some maps.
I followed the instructions of the installer and followed a Youtube tutorial as well on how to download/install SCM Draft 2. However I keep getting an error that says,

"Error::nable to initialize scmdraft’s game engine!
(hr = 0x80070002)
Launch with the -console command line for detailed error info.”

I have downloaded the most recent version of SCM 2 Draft and put it in the Starcraft folder. Starcraft is also downloaded and plays just fine.
I have tried putting SCM draft 2 outside of the starcraft folder but it still won’t launch.
I have uninstalled SCM Draft 2 several times but nothing changes.
Any ideas on how to fix this?

Hi! Here you go:

and here:

Next time try using search, if you haven’t already :slight_smile:

I’m using ScmDraft 2 Version 0.9.10 (Beta) and it works fine for me with the latest SC.

Thanks for the response.
The problem is I have read those threads and tried what they suggested already. I’ve downloaded the 0.9.10 version but that same error message comes up. Just uninstalled SCM draft and re-installed again but still the same error.
Any other ideas I should try?

1 Like

You’re welcome!

Did you try to launch ScmDraft with the “-console” parameter?
If you don’t know how to do that, read this article:

You’ll see in the article “-private-window”, replace that with “-console” when it comes down to ScmDraft, of course after you’ve made already a shortcut to ScmDraft.exe .

If you’ve done everything right, when you’re starting ScmDraft from the shortcut, a cmd prompt will pop up, like here:

Print out here what the errors are, maybe I can help further.

You can also try this: once you start ScmDraft, under the “Default” profile, hit “Edit” and go to the “Game Data” tab and pick “Custom” and locate your StaCraft folder. Maybe your SC is not in the C drive and SD can’t detect it.

Also try to mess around with the other settings under the “Default” profile.

Hello again,

I’ve done what you’ve told me to try. The console thing says this,

" Console - (ENGINE) Preparing to launch ScmDraft 2.
ScmdraftApplication - 04:25:51.0583 - Debug::Creating the application instance.
ScmdraftApplication - 04:25:51.0591 - Debug::Running FinalConstruct().
ScmdraftApplication - 04:25:51.0595 - Debug::Running profile select window.
Settings - 04:25:52.0954 - Debug::Unable to read the starcraft path from the 1.16 location.
Settings - 04:25:52.0961 - Debug::Unable to read the starcraft path from the 1.16 location.
ScmdraftApplication - 04:25:52.0990 - Debug::Initializing the main editor engine.
ScmdraftApplication - 04:25:52.0998 - Info::(ENGINE) Using the Default profile.
ScmdraftApplication - 04:25:53.0002 - Debug::Creating the game data holder.
ScmdraftApplication - 04:25:53.0010 - Debug::Initializing and loading data MPQs.
DataAccessor.CASC - 04:25:53.0201 - Debug::Opened CASC storage located at: C:\Program Files (x86)\StarCraft
ScmdraftApplication - 04:25:53.0209 - Debug::Loading data files and string tables.
GameData - 04:25:53.0213 - Debug::Preparing to load starcraft datafiles.
DataAccessor - 04:25:53.0229 - Warning::Unable to load a file (SD\game\tselect.pcx) from the CASC storage.
GameData - 04:25:53.0238 - Warning::Could not load the selection circle colors (hr=0x80070002, CDataFiles.cpp, 1090)
GameData - 04:25:53.0246 - Warning::Could not load the global palette lookup tables. (hr=0x80070002, CDataFiles.cpp, 160)
ScmdraftApplication - 04:25:53.0254 - Error::nable to initialize scmdraft’s game engine! (hr = 0x80070002)
Launch with the -console command line for detailed error info."

I also tried messing around with the profiles and did the edit game data/ custom path directly to the StarCraft folder but I got the same issue.

Thanks for any help!

Hi! Hmm. I’m not sure what it could be, but having a look at it, it seems SCMDraft couldn’t load datafiles located at C:\Program Files (x86)\StarCraft from the CASC storage.

Google for casc storage starcraft to find out more about CASC storage, because I found some results.

What I’d try next is to uninstall Starcraft, uninstall ScmDraft 2, then delete all leftover files belonging to Starcraft, restart PC, then reinstall both of them. You can use Everything to find all folders called Starcraft and delete leftover files.

Here’s the link to Everything:

I forgot to ask you what OS are you using, Windows 10?

You’re welcome! :slight_smile:

1 Like

Actually, if you’re using Windows, before performing the uninstall/reinstall procedure from the post above, you should run chkdsk or/and sfc /scannow from command prompt (run it as administrator), to make sure everything is fine.

The difference between the 2 of them:

Here’s on how to use chkdsk:,fix%20them%20without%20a%20command.

Here’s on how to use sfc:



I did the scans and everything came back clean. I uninstalled both, restarted the computer and then re-installed and now it works.
Thanks for all your help!

Hi! You’re welcome! :stuck_out_tongue:

Can you mark the post that helped you as solved, so it would be easier to find in case other players encounter the same problem?

Also, something that might help you in the future as well. If the scans come out clean and uninstalling/installing doesn’t solve the issue, then it might be something wrong with the registry (registry is where Windows stores settings of a program).

To fix up registry issues you can use AVG Tune Up, which I assume it was recommended by Blizzard support, according to this post:

CCleaner does the same job, but I assume AVG Tune Up must be better for Stacraft, if it was indeed recommended by support.

Before using any of those tools create a restore point in case something goes wrong with the registries, so you can restore Windows from an older state.

In general, registry tools are not recommended, because they can make your system unstable or maybe it can break it up completely if something goes wrong. But if support recommended it, they must know what they are doing.

Having messed around manually with registries in the past, instead of using any of those 2 programs, I’m using a monitoring program like Total Uninstall, which tracks down where each file, registry is created for the program during installation and it shows that to me in a clean interface. That way you I can decide for myself what leftover files/registries I can remove. Of course, before using this tool, I’m creating a restore point
as well.

Links to all tools/info here:,a%20backup%20of%20the%20Registry.

Just as a clarification Blizzard never mentioned which programm to use, but rather detected with me that my registry was at fault. The actual solution was to create a new Win10 user account with admin rights and move everything to that account since it has a clean registry.

But as I did not want to do that before trying to cleaning my registry, I have tried several Clean Up Utilities and the one tool that helped me happend to be AVG Tune Up. Never did the Tech Support tell me to you that programm in particular.

BTY I have also started before with CCleaner and an other tool (whose name escapes me) before testing AVG TuneUp. Only that the latter was the programm to help with the laggy SC menu.

Hope you guys can figure out your problem

Thank you for letting us know about how it exactly went for you back then! To be honest, moving everything to a new account is a lot of work, and I would’ve tried the same - I’d be trying to fix the registries.

We have already solved the problem, you must have missed some of our posts above! :stuck_out_tongue: