Unable to connect online

After the loading screen it takes me to the log in page of Starcraft 2. I just changed my email account that is used for my battle.net log in and I am not sure if that is the issue. On the Starcraft 2 user log in it tells me that there is a maintenance at the moment which I know there isn’t on the battle.net store there is not notice of any maintenance under way. Does anyone know the issue I am experiencing?

5 Likes

Howdy Ultima1806,

In this case, try reinstalling the game.

im having the same problems past few days. today is TG.

Have you tried reinstalling the game?

I am experiencing the same issue. I have reinstalled the game and able to connect to the battle.net, yet when SC II starts I get a message that the server is down for maintenance. It does not allow me to play offline. This is a new computer. I am not having issues with other games. Can you help?

1 Like

buenas estoy tiniendo pronlemas entrando online no me sale los modos del versus ni nada a ver si me lo pueden arreglar

everytime i launch the game it doesnt connect to online services and when it does only stays up for 3 to 8 mins before cutting off how do i fix that?

Ho lo stesso problema da mesi co STarcraft2.
Ho disinstallato e reinstallato già due volte.
NON RISOLTO NULLA.
Heroes of the storm ed altri giochi tutto ok
Cosa fare ? Grazie

I have the same problem. I just installed the game after not having played for many years and I can’t even play because it either says authentification error or the game is under maintenance. I don’t think re-installing would work as I literally just installed it.

1 Like

Same here. I’ve tried to play multiple times over the past couple months and everytime I get the same issue. Game loads but I get the “Error: Battle.net is down for maintenance. Please try again later.” So frustrating.

2 Likes

Howdy y’all,

To clarify, is SC2 being installed through the Blizzard app? If so, let’s try testing another network like a mobile hotspot to see if there’s any change. Alternatively, try testing a free VPN.

I’ve tried:

  • reinstalling the game: didn’t work
  • deleting battle.net cache: didn’t work
  • changing DNS servers: didn’t work

I’m using Mac with BigSur.

Getting same battle.net authentication error. The game did work yesterday.

I have not been able to connect for several days either. Just says logging in… and never does

I have tried uninstalling and reinstalling multiple times. I have a physical copy not a digital version. The game patches like normal and starts fine, but when I try logging in I get the “servers are under maintenance try again later” message. I have changed my password and removed/added my authenticater multiple times as well. To no avail. Why is this still happening. I have been a customer for years and never had this problem until recently.

1 Like

I have been having the exact same problem. How long does it take for Tech Support to get this fixed? or provide another suggestion to get our game running?

Ver 5.0.5.82893 PTR

Just uninstalled the game, then re-installed it, and everything works fine again.

To clarify, you should not be using the physical CDs to install the game if that’s what you are trying to do. Log into the Blizzard app to install the game. If this doesn’t help, try testing another network.

Swapping to the Beta version of the Blizzard app has also helped some players:

  1. Click on the Blizzard logo at the top-left corner of the App
  2. Choose Settings
  3. Choose Beta
  4. Click on Switch to Beta
    * Note : If you are already using Beta, try switching to the Standard version of the application. Choose Switch to Standard Version instead of Switch to Beta
  5. Delete the PTR executable if it exists
    • Go to the StarCraft II tab in the Blizzard Battle.net Desktop App
    • Click Options :gear:
    Choose Show in Explorer
    • In the Starcraft II folder, delete the StarCraft II Public Test (.exe) file
    • Note : If you do not have the Public Test file in the StarCraft II folder, check to see if you have the PTR installed and delete the Public Test file there instead
  6. Uninstall Starcraft II
  7. Reinstall StarCraft II through the Blizzard app
1 Like

Hopefully, this will help some people. I was getting the under maintenance message. Not really wanting to reinstall the game, I first tried reinstalling the Blizzard app. Nothing, so I tried switching to the beta. Still nothing. I finally was able to get the game working by going into the game folder and deleting the StarCraft II Public Test .exe. All good, at least for now.

2 Likes

Hey Hunterkiller. Your little work around worked for me. I have been loading from my disks. If others have been having the same loading problems do this work around. Thank for the post

1 Like

Thanks. I’ll take any credit I can get, but I did get this from the Blizzard rep’s post just above mine. I’m just letting everyone know that it did work for me.