Trouble Publishing My Custom Map

When I tried to publish my SC2 map(I’m new to the mapmaking), the uploading stage it gets to 5-18% then I got an alert saying the upload failed. There also is an error saying something about how I ‘Need to upgrade my copy of StarCraft 2’. So I deleted some of my most recently added doodads, and then when I tried to publish again I got the same error at 99%. I tried again and I got the error at 100%. Then I decided to check if it was just my map, so I created a new map, changed the name and description, then tried to publish it. I got the same error at 99-100%.

My map is a 6v6 for me and my friends to practice against AI.
Ok so I tried to publish again, and this time it got stuck on 15% with the same error. There also is an issue with “Transmitting Header File”.

Anyone have any ideas on how I could fix this?

I saw another topic with the same issue as me, I read through it but there was no solution to the problem. I’m posting this in hopes that someone does have a fix for this issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.