Starcraft turns bluetooth headphones into potatoes

Using macOS 10.14.6 Mojave, on a late 2013 iMac.

When Starcraft 2 starts, the quality of audio from my Bluetooth headphones massively degrades. When I check the bluetooth audio codec that’s in use (by Option-clicking the Bluetooth icon in the menu bar), I see that it changes from AAC (or perhaps ACC, I don’t remember) to SCO.

I also own Diablo 3, which doesn’t have this issue.

I’ve observed this effect with:

  • Bose QC 35 ii
  • Jaybird X3
6 Likes

I have the same problem. Was a fix ever introduced?

Same problem! pls fix bug!!!

Some additional information on the cause of this bug, how to reproduce the issue and a workaround until Blizzard resolves the issue.

The issue appears to be a result of the way that Blizzard treats bluetooth devices that have both inputs (microphones) and outputs (speakers). When you connect a device that has both input and outputs, it appears to switch the sound over to some type of “headset” mode that disables any noise cancelling and causes the audio to stutter profusely.

This issue can be reproduced by connecting any(?) (I have seen the problem with Bose QuietComfort 35 II and PowerBeats Wireless) bluetooth headset that includes both a microphone and speakers.

As a workaround until Blizzard looks into this issue, you can get your sound working by performing the following steps prior to launching Starcraft 2.

  1. Connect your Bluetooth headset
  2. Open System Preferences -> Sound
  3. On the Input tab, change the input device to the built-in microphone on your Mac.
  4. Launch Starcraft 2

This was tested on a Late 2016 MacBook Pro running Mojave 10.14.5.

From what I have seen, there are similar issues which occur in Windows caused by the same issue. While I do not have exact steps to follow for Windows, I would expect changing the Input device would produce similar results.

16 Likes

Sir, you are a genius, I have the "sony wh1000xm3 " and had the same issue, this also works in windows!

thanks!

this works, thanks a lot! also select device in sc audio settings.

1 Like

I’ve noticed the exact same audio quality degradation in other contexts that use my microphone (e.g. video conferencing).

Turns out it’s a bluetooth issue, not an SC issue. There simply isn’t enough bandwidth for the same quality of output audio, when you also need to make room for input audio.

This is expected behaviour. I can’t post links here, but if you Google [Bose QC35 S1] - terrible sound quality with mic, you can find a forum post on the Bose site, with a response from a mod named Mohsin_S, who explains this is normal behaviour, and simply a compromise made to support two-way audio.

Awesome !
I was going crazy , now peace has returned to my ears,
Thank you so much !

Holy! That worked like a charm on my wireless Bose headphones. Thank you so much! Note, I also have issues with the headphone input when using the same ones for video calls at work.

Hi Blizzard,

any plans to fix this problem? The workaround is great, but not when you actually want to talk to your teammates while playing. And no, this is not a bluetooth problem. Various headsets work perfectly well with both input and output sound in a wide set of scenarios, but not in SC2.

Cheers

1 Like

I’m running Catalina on my Macbook pro and have the Bose QuiteComfort 35. I was running into the issue of the people hearing me was like I was in a garbage
disposal, a lot of static. And their voices would only come out of the ‘headset’ setting, which means the plugged in speaker. (I’m running my computer in a doc) I’ve tried the suggested solution but isn’t working, in the sense I can’t hear any sound coming from my headset. I’m wondering what should the settings be in the Game? I’ve noticed there are two sound settings, one in the battle net application and the other in SC2 settings. - I’ve tried all different settings.

My latest test was not having the computer in the doc, and running the suggested solution. But my budder was able to hear me loud and clear, YEAH. but when they talked his voice was still coming out of the computer.

On a laptop running windows 10, all I did was to go to Control Panel\Hardware and Sound, click on Sound. At playback i selected Headphones as default device the others should appear only ready with nothing green on them, and at recording I selected laptop built-in microphone as default, and disabled (it’s a must) the headset. I am using Sony’s MDR-XB650BT headset.
And, in windows 10 settings, at Sound, check that the output to be the headphones and at input device to be selected the built-in microphone

2 Likes

I have done all of the same Windows settings in Control Panel and Settings as St3fun, but SC2 still degrades the sound as soon as it loads up. I’ve tried all sorts of voice chat and sound settings in SC2 as well, nothing makes my Bose QC II bluetooth headphones work. I was able to solve this issue in macOS Catalina by using system settings to select the mac mic to be the default mic, but not Windows.

  1. Open Sound Settings
  2. Disable all Input Audio Interface
  3. Launche Starcraft 2 and wait until you hear some sounds
  4. Alt+Tab to Windows Re Enable Input Interface if you want to voice chat
1 Like

I confirm the fix. In my case I have Sennheiser MOMENTUM 3 Wireless and I have 2 devices in sounds output, one for stereo and one for hands-free, the latter one also showing up in input tab. As the mic is not that good on this headset, it is safe to not use it… so I disabled the hands-free version and now I got my normal sound in SC2.
Thanks!

1 Like

Thank you - this was spot on!

1 Like

I’m having the same problem with sony wh-1000xm4 on MacBook pro macos Big Sur.

Thank you… All these years of low quality audio bluetooth headphones … This works. Thank you.

Great fix! Thank you

I found this video to be very helpful for Windows:
SC2 Bluetooth Headphone Issue