Starcraft 2 never loads have to force quit task manager

A couple weeks ago Starcraft 2 stopped loading entirely. No updates or any changes in my environment to cause this issue. I have tried every suggested fix on the internet. Complete reinstalls, new admin account to run the game, change any onedrive settings, and deleting any temp/appdata folder remains that I can find.

Once I click play from the BattleNet app nothing happens. No screen flash like it wants to start, nothing. I then have to open task manager and end task on the SC_x64.exe that is running.

I am hoping to see if anyone else can offer up some suggestions as to what may have fixed it for them. I have uninstalled any recent windows updates, pretty much anything I can think to remove old or temp files from my machine that could be maintaining settings. Please help.

I’m having the same issue - game begins to launch, then minimizes and won’t open/load. I’ve tried all the troubleshooting that I can think of. A friend has the identical set up as me, same motherboard, gfx, processor, ssd, drivers, etc etc and his seems to be loading without a hitch. I don’t know what to do.

I’ve got the same issue. Clicking “Play” in the app leads to literally nothing. It’s starting the process “SC2Switcher_x64.exe” and “SC2_x64.exe”, but there is no window, no icon in the task bar or anything else of the game starting. I am also not getting an error when terminating the processes. Once in a while it’s showing Error (2:1), which doesn’t really help.
I was hoping for the latest patch of SC2 or the latest update of the app to change anything, but the issue remains the same.
I also already tried eyerything to change on the system, apart from reinstalling my whole computer and all the hotfixes for any other starting issues, but nothing seems so change the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.