Problems with authentication since the last patch


#1

The game no longer starts automatically as it did before the patch. It asks for the authentication code every day. Although I do not have that problem with the blizzard app or with other games, it only happens with sc2 and since the last patch. Also if I close the game without login it throws me the error message: CC71C109-98F8-4206-BD5F-76D641D980EE. Is this a bug? I tried to disable the antivirus but it did not work


#2

Hey all,

We started getting reports of this a few days ago, can anybody else with this behavior please post your crash code in this thread? Here’s the behavior we’re looking at:

  • Problems logging in to the game through authentication
  • Crashes when you exit from the login screen

We’re digging into this now, so we appreciate you reaching out and letting us know. Any reports right now will be helpful as we try to narrow down what’s going on here.


#3

6A9F7D37-6029-44BD-BA15-AEFC0C96F9DB
I’m having the same issues, i cant event manually get in with my username and password


#4

Hey again everybody,

We heard back from the devs. They’ve identified the issue and are working on a fix. Please continue to report issues with authenticating to the game servers followed by a crash on close in this thread!


#5

458A5E26-8096-4521-BB03-53E13CBB2FA9
My game will launch, but then immediately go to the login menu. It does not let me press login even after I enter my credentials and the button is highlighted.


#6

i started experiencing this about 1 week and 1 day ago. Here is my crash code:
57BFED37-707F-4230-938B-26DB624D6BF3


#7

Same problem as described above i enter the game and it takes me to login menu.
If I quit the game gives the folowing error code:
59631967-E51C-4394-B9E1-71F49ED6F449
This started after the last update.
Best regards


#8

I just tried to login as well and after entering username and pw and auth code I received invalid credentials

When I closed SC2 I saw the following error code: 00510924-5F84-4DB4-B8FD-A54B81A46B92


#9

Same for me. Report ID:
6EF4D410-FE0B-4006-B615-FFAC3A12CF9D


#10

Same problem as described. I enter the game and it takes me to the login menu. When I quit, it gives me an error code.
Here is my code.

EA288AA8-C560-4BDD-B62C-ADA8292E8AD0

Thank you.


#11

Same: E7E5E763-A3F6-4049-A0D2-0E872829E821


#12

Same here. Can’t login. “An unexpected fatal error occurred”. 47A6EED3-D2E0-457A-A842-C563472924D4


#13

The bug was fixed with this patch :slight_smile:


#14

Getting a Version Mismatch error that I’ve never received before. Tells me to restart the game from the launcher after I patch. But… same thing happens every time I restart and relaunch. Current Version: 4.9.1.74456 running on a 2015 MacBook Pro.

UPDATE: all is well… i had to restart my computer for the DL patch to start downloading. never had to do that before :confused:


#15

Hey all,

We’re starting to get positive reports as of the latest patch. Can everybody here ensure that you’re updated test again? If you continue to have problems, repair your game client.

If even that fails, and the problem you are having is authentication failing, and crashing when you close the game, please post here.


#16

“An unexpected fatal error occurred”
5F9DFDE6-026D-450E-A030-2F2E3670915D

Hi,
I have the same problem.