Possible ultrawide bug? SC2 won't launch in fullscreen

Hello!

Hoping someone else is having this problem and can help. I recently upgraded to a 5600x cpu and RTX 3080. I’m not 100% sure the problem happened at that time because I took a break from sc2 for a bit but I have to think its related. I am also using a 21:9 monitor that runs natively at 3440x1440 and I tend to run starcraft fullscreen at 2560x1440 if possible.

The problem is that when I launch sc2 it keeps alt tabbing back to windows and won’t let me stay in the game. I have a video showing the issue, but this won’t let me post links.

Any help or suggestions are appreciated. It does appear if I keep my desktop resolution at 2560x1440 I can launch the game fullscreen, but then I can’t alt tab.

Hey Zebulon,

Starcraft II doesn’t support ultrawide 21:9 resolutions unfortunately, but it should allow you to run in Windowed Fullscreen at a 16:9 resolution with black borders on the sides.

If the game won’t stay up long enough to get into the options menu, you can try changing the Variables.txt file and edit the display mode there to set to to Windowed Fullscreen.

  1. Open the Documents\Starcraft II folder
  2. Open Variables.txt with Notepad
  3. Find displaymode and change it to
    displaymode=1
  4. Save the file and try launching the game again

If that doesn’t work, go back in and change it to displaymode=0 for Windowed mode and see if that allows it to stay on screen after launching.

Thanks for the tips Jambrix.

While I am able to get the game to launch in both Windowed and Windowed Fullscreen, I am not able to get the game to launch thereafter with black bars using either of these options. Again, I can launch the game with Windowed or Windowed fullscreen and then CHANGE to fullscreen while in game. If I change to full screen I do get black bars (and its displayed correctly). However, if while in game as fullscreen, if I alt tab (which is now working) it will not let me tab back into the game. So I am still not fixed, other suggestions?

I think Alt+Tab is not supported in Fullscreen, only in Windowed Fullscreen, even if it still work in many configuration.
Maybe you need to edit Variable.txt, seek the width and height entries (it seems to be in alphabetical order, so they are far from each other), and set them either to your 21:9 values or the nearest 16:9 values, and play in “Windowed Fullscreen” like that?

Thanks for the reply Undead.

I have now found a solution for me:

Disabling “Windows Security notification icon” in task manager/startup.