My game can't launch please help

Hei guys, I was playing yesterday just fine and today when I try to start my game, it tells me my game is running, there’s no text on that loading bar that shows up and the game just refuses to load
I have the newest Nvidia drivers, I tried repairing and I tried disabling some printer thing I found in a youtube video but still doesn’t work so like, any ideas?


same here, I tried to reinstall too only to spend an hour “prepraring” and so far 2+ hours(as of writing) in the install process at 0%

1 Like

yea same here, there are multiple threads about this but no fix from blizz.

1 Like

Hi All,

Same here, yesterday everything was working fine, now starcraft is not starting (the editor is also only “loading”).
Hopefully it will be resolved soon.

Same problem and another maybe related one:. I fully removed the Battlenet client and found I install it after downloading it, being stuck in “Updating Blizzard Agent”.

Switching to a Backup copy of the Client I can in fact login, however then I get stuck in: “Blizzard Agent went to sleep, Attempting to wake it up…”

If you google, you can find that this has been a problem for over a year now. Blizzard simply doesn’t respond or care.

same here. yesterday everything was fine.

Today first loading, then after uninstalling Battlenet it’s stuck “updating blizzard agent” for hours now while trying to install BN again.
The installation log repeats the same error over and over:

W 2020-08-05 18:02:57.647707 [Main] {2cec} Downloader - {2cec} WRN (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 2080): HTTP: connection timeout for ‘’
W 2020-08-05 18:02:57.647765 [Main] {2cec} Downloader - {2cec} WRN (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 2080): HTTP: connection timeout for ‘’
E 2020-08-05 18:02:57.647884 [Main] {2cec} Downloader - {2cec} ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 392): HTTP: connection failed for host NET_CANCELED
E 2020-08-05 18:02:57.647977 [Main] {2cec} Downloader - {2cec} ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 392): HTTP: connection failed for host NET_CANCELED

Same here. Yesterday everything was fine, but today the game is not launching.
Updated Radeon Drivers, tried everything that [BastionIsFun] mentioned above.
StarCraft 1 is working though.

I solved the issue! Disable the internet connection and launch the game. It seems thatn something died on the Blizzard servers.

Call of Duty and his 60GB patch are to blame.
After starting sc2, it connects to Blizzard’s servers to check MD5. The servers are overloaded. Sorry for my English.

1 Like

How can I do that ? It is said - "Unable to download game data from Blizzard’s servers. Please check your internet connection and try again later.

Yeah blizzard servers are probaly financed as well as regular employees, lol.
Their servers had multiple long-lasting malfunctions throughout the week.

For me the game download and patching works. I did it from the launcher. Then, when I start the game, white window with progress bar appears. It seems that it is the moment when it tries to connect a server and fails. Disconnecting an internet cable or disabling an internet connection helps to bypass this window and the game starts. Then you can select offline mod. But I guess there can be tons of other issues as my download speed jumped yesterday from 5kb/s to 3Mb/s.

my game is stuck as well. Sometimes it launches smtimes i have to wait like 1 hour. WTF BLIZZARD

Same here for the second day now. Disconnecting internet will start the game immediately but then I have to play offline or wait the same time for connection to Blizzard services. Fix that crap…

Another day, same problem.
Blizzard should be ashamed, but the people that cared were laid off by Activision a long time ago.

Okay, I got another problem, some hours ago I could start SC in offline mode but now even that is not possible. Everytime I get an error that files cant be downloaded. This is strange because I use the same procedure as before…

I used the scan and repair tool but the problem still exists and my gameversion needs no update

For those who get error that update files can’t be downloaded from servers while launching Starcraft 2 with no internet connection:

  1. Launch app.
  2. Launch task manager (for Windows: Ctrl+Shift+Esc).
  3. Terminate Agent.exe process.
  4. Disconnect from internet.
  5. Launch SC2Switcher_64.exe (or SC2Switcher.exe).
  6. Connect to internet after the game successful launch.
  7. Enter your credentials from inside the game.
  8. Play.:wink: