Mouse slow/broken when dragging — Mojave 10.14.5

Happens with Logitech G303 wired mouse, or Apple Magic Trackpad 2. Happens inside the game or in the main menu screens.

Basically, any time the left moue button is held down (e.g. like you would do to to drag across a selection of units), moving the mouse is EXTREMELY slow/laggy. And it’s not even slowed to a predictable degree, it’s just absolutely broken because sometimes a drag of 6 inches produces almost no movement, and other times it will go across the whole screen.

I compared it to dragging on the desktop and neither the trackpad nor the moue have this issue.

What’s going on here?

EDIT: Quitting BetterTouchTool seems to have fixed this. We’ll see if this is a lasting fix.

EDIT 2: There’s still a problem where, if at any point I use middle-click-drag-to-scroll, then thereafter the cursor refuses to move DOWN unless with a big motion. Happens with trackpad or wired mouse—_after_doing a middle click drag scroll.

Hey man, I have a similar problem.

OS: MacOS 10.14.5
mouse: Logitech G600

My issue is just a little different. My cursor sensitivty feels like it intermittently slows when I am using hot keys to select control groups.

For instance, say I bind my Command Center to 5 - if I hold down the 5 key, my mouse cursor just drags, intermittently.

So when you are trying to both attack and macro this gets REAL tough. you are selcting all sorts of control groups in the mid game while trying to macro/micro and it’s like your mouse is lagging the whole time.

this only happens with the Logitech G600 in my case. I’m about to make a separate post about it.

I also have this problem.

OS: MacOS 10.15 Beta (happened on Mojave as well)
mouse: Logitech G Pro

I’ve talked to several people on Twitch that also have this issue and it basically makes the game unplayable.

Howdy!

We are still investigating Mac Mouse issues. Some workarounds posted Here may help troubleshoot this issue to full resolution.

Thank you!

I’m runnign LOTV on a Mac - and I’m having a weird mouse issue. I’ve tried two different mice same problem. Sometimes, the cursor will get “stuck” over a building, mineral patch, etc… and to get it unstuck I need to make a drastic move of the mouse, like all the way to the side of the screen. When it’s stuck, it seems like for a second the cursor is “jumping” between two different but very close together points on the map. It’s very annoying, and makes it difficult to play. I’ve messed around with a bunch of the mouse options in the settings but nothing is helping. Outside of the SC2 game, my mouse works perfectly. Ideas?

Device: MacBook Pro (15" - 2018)
Graphics: Radeon Pro Vega 20
OS: macOS 10.14.5
Mouse: Logitech G600 (Logitech Gaming Software Release Version - 9.02.22)

SCII Settings:
Display Mode: Windowed (Fullscreen)
Keyboard:
Disable OS Keyboard Shortcuts checked
Use Command instead of Control for hotkeys checked
Use standard function key behavior checked

Mouse:
Enable Mouse Sensitivty: un-checked
Reduce Mouse Lag un-checked, about to test checking this one

This is hard to describe, but here is an example:

Say I bind my Command Center to 5 (or any other key). If I am moving my mouse while I select control group 5, the mouse cursor will drag. It’s as if the cursor sensitivity drops whil I am hitting the key to select a control group.

So, to be clear - this “drag” on the cursor only happens while I have any control group key pressed - also, the control group has to have units or building assigned to it (meaning if the 1 key is not assigned to any groups, it won’t cause any issues)

I’ve tried updating everything. I’ve tried a different logitech mouse and did not experience the issue, so it seems to be specific to the G600. I’ve searched the web and found that a lot of people have to disable a bunch of settings in the Logitech Gaming Software, but nothing there has helped.

I’ve posted this on reddit, but not much traffic on it. I found a post from a while back on the old forum site with the exact same problem, but no replies.

I can’t explain why this is happening, but I can barely move my mouse when not in game. It’s almost unresponsive. Starcraft is the only application where this phenomenon exists and it only seems to happen when I’m not in-game. I have to make MAJOR mouse movements just to move a few pixels on the screen. It’s really bad. Tried with and without Razer Synapse software running just to rule that out.

Hello,
I have same issue. It seems it has not yet been resolved since TWO YEARS AGO, Hey BLIZZARD SUPPORT, @zuvykree , PLEASE ADVISE!

Thank you.

In “Options” → “Video” try unchecking “Enable Vertical Sync”, i.e. disable vertical sync.

While vertical sync is on, pressing any keyboard button slows down mouse movement speed and makes its behaviour erratic. Unsure why.