Hotkeys and default settings

Every time I start SC2, it shows me the opening cinematic and tells me that my graphic settings have been set to default. I also cannot change any hotkeys - when I edit the hotkeys SC2 tells me I cannot overwrite the Standard hotkeys and I must create my own profile. Once I hit accept and save, the hotkeys go back to being Standard and the hotkey profile I created disappears.
I have my folder settings that SC2 is saved in as both read and write? Also I am on a Mac if that is important.
Basically I cannot play the game right now and it is a huge bummer. Would love to be able to go back to setting my own hotkeys .
Thanks!

1 Like

I’m having the same problem. I think I hit reset to default by accident and it erased my hotkey profile. Now I can’t change anything, and cannot play at my normal league level because my keys are all wrong. PLEASE HELP BLIZZARD.

Hey hopefully you guys see this, but I had the same issue on a Mac tonight. You have to find your SC2 account folder and enable execute permission on it. I’ve noticed my M1 has a different folder structure in some cases, but I found mine at /Users/{username}/Library/Application Support/Blizzard/StarCraft II/Accounts/{accountNumber}. Basically, you want to get into this folder where you’ll see a folder named Hotkeys that you won’t be able to open. From a terminal in this directory run chmod u+x ./Hotkeys. Both you and the game should be able to access this folder now, and you’ll probably see that your profile is still there.

TL;DR
Open terminal

cd /Users/{username}/Library/Application\ Support/Blizzard/StarCraft\ II/Accounts/{accountNumber}
chmod u+x ./Hotkeys

In case you don’t know your username/account number:

cd /Users
ls # you should see a folder called Shared, along with your username
cd {username}/Library/Application\ Support/Blizzard/Starcraft\ II/Accounts
ls # you can see your account number here
cd {accountNumber}
chmod u+x ./Hotkeys

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.