Contract Saviors Achievement not working

Confirming that after several failed attempts with Medics, building no Medics ended up getting me the achievement for Band of Brothers.

2 Likes

No, what I meant is that even when killing all the buildings by 3:11 (with the completion delay looks like my quickest completion is 3:51)… I’ve gotten to the 3rd building with a modest force with roughly 2:40 on the timer and there are zerglings completing just as I arrived… so I highly doubt it is possible to complete it quick enough to avoid the AI building units… we will need to wait for Blizzard to realize their mistake and patch this.

Update: I just ran this mission a few times with the new patch/update… and it is still broken (completed with no losses, not mining a single mineral, no building anything, in about 6 minutes with only the units we are given… as well as my quick-method where I build 1 medivac and rush all buildings at once (and lose plenty of units) and complete in around 3:15 (but after the talk-scenes finish around 4:00)… and still no achievement.

Please Blizzard… while you are fixing whatever is wrong with multiplayer, please correct this achievement.

1 Like

Same issue here, had to replay the mission multiple times and still no luck.

1 Like

Omg this! I just noticed it from the screenshots too, as I gave this mission another 2 attempts this morning I trained Medics both times even tho I avoided using Raven’s abilities, Vulture’s mines and Mules. Gonna give it another try tomorrow to see if Band of Brothers will finally pop for me.

I was super confused about this one… looks like someone didn’t test it before shipping.

Details can be found here:

Issue is still present, hopefully they fix it by the time I get the rest of the Achievments

2 Likes

Only issue i have is with “Contract saviors”.

As you can see “Band of Brothers” works fine

ht tps://i.gyazo.com/bdb6678acbd673812629c288bb8c16cc.jpg
(Sceenshot of the achievement apparently can’t add links or ss)

The way i did it is collecting most of the gass across the map.(ASAP)!
So with few Marine Marauder Medic (MMM) (The units you start with).
Grabbing as many resources as possible while clearing and upgrading

then with all the gas Starport and mix in ravens with the 100+ energy start perk its easily do-able i ended up with overcapped supply and massive army just stomping over the nydus worms with 8~10 ravens which could do 1 of 2 things drop point defense drones to stop ranged attacks or auto turrets in front of marines as a buffer while dishing out more dmg.

As for vultures… yeah no thanks not even worth the rescue. :smile:

Alternatively a quick fix would be changing these marines to merc marines, which would still satisfy the requirement of “mercinary” but I feel you are correct - these 4 marines may well be the issue that is causing this problem.

The achievement Band of Brothers uses the exact same trigger logic as Contract Saviors and everything rescued in that mission is non-merc. So the regular marines at the start of Moebius Factor has no effect on the achievement.

The issue with Contract Saviors is that there’s a line of code missing the the trigger that allows the AI to fail the achievement for you.

2 Likes

OP said that it isn’t the AI building units that causes it; the AI only builds after something is attacked near the hatchery. But what if units are built at the start, before you have vision of the hatch? Could someone try typing in TookTheRedPill to remove fog of war to look at hatcheries and see if something builds to confirm?

I’ve done this. The only unit that appears to get built 100% is a mutalisk in the bottom left base @ the 3:00 mark. It hatches (finishes building) around 3:30.

I’ve managed to complete the mission by 3:22, cutscenes (I trigger the longer audio cutscene earlier to avoid a delay in finishing) and everything finished without the mutalisk hatching, but no achievement was awarded. Even if something were to be built by the opponent before this mutalisk, which I don’t believe there is, it wouldn’t be possible to complete the mission prior to that time.

-Valas

1 Like

I’m having the same problem. Just finished the mission for 2 times (without building anything, just using the units i found) and it doesn’t work.

I have completed Contract Saviors and got achievement. If you’re available join this discord, going to show replays of how to do it @ 8 P.M. EASTERN STANDARD TIME on 08/01 (much easier than typing).

discord.gg/nBaW9Q

-Valas

Same issue here on Contract Saviors - The Mobeius Factor , completed building nothing 6.22min, building only scv, build only scv & medivac, building merc , med & scv. Still no achievement…

I’m uploading a youtube video on how to complete this. It’s still downloading. It takes a bit of work to get and you have to finish by 3:30. Stay tuned.

-Valas

Link to youtube video: https://www.youtube.com/watch?v=hZmF1bpu_TE&feature=youtu.be

I never make videos, so if the quality sucks, blame it on my first time. Timestamp @ 10:00 proves the awarded achievement.

This took me several hours to figure out, and considering I can’t receive the achievement a second time, it’s not a “perfect” run in that sense. (Notice the amount of saves I went through). Regardless, following the main steps I discuss in the video is all that is required to successfully finish.

Ask any questions you may have.

-Valas

1 Like

thx for the video valas i gone try again but uff i hope they can fix it, look very very hard to do in 3.30 xD

You bet! Just keep trying, save often, and slow the game speed down. Once you know what to do, it becomes a lot easier.

If you do keep trying, and keep getting caught up on a certain spot, let me know and I can provide some more insights.

-Valas

I have finish before 3.30 but it didn’t work i saw your vidéo but can you link you acheive ?