Contract Saviors Achievement not working

I am having an issue with this achievement on the Moebius Factor campaign mission. The tooltip states we only have to beat it on normal while only training SCVs, Medivacs, and Mercenaries. I have beat this 15+ times on a new campaign fulfilling those requirements in different ways. I have tried:

  • Meeting that requirement but building buildings for supply, etc…
  • Not building anything at all (completing mission with only what I start with and the rescued units… no buildings, no units, no upgrades were built and no minerals/gas mined)
  • Not killing any zerg with anything except mercs / rescued units (moving the 4 normal marines we get in the beginning to a corner and leaving them there)
  • Beating the mission with only rescued units and not losing any units while not building anything
  • Beating the mission with only SCVs, Medivacs, Mercs and destroying the zerg base prior to completing the mission, and also killing all buildings I can find on the map
  • Beating on brutal with only SCVs, Medivacs, Mercs and rescued units
  • Killing and not killing the brutalisk for most of what I stated above
  • Using only rescued units, SCVs, Medivacs and map-hopping to kill buildings Kerrigan is searching so she doesn’t complete a search on any buildings.

Nothing I have done has given me the achievement.

This achievement is broken. Please fix it.

Update:
I can confirm it isn’t the AI building units that is breaking this. After many attempts and my quickest completion being 3:44 (by the time the NPC chatter ends)… I started to notice patterns with how the Hatcheries started building units. I figured out it isn’t time (as no matter how quick or slow I got to the last building, there was always an egg-qued by the time i got there)… but sometimes with my suicide-runs they wouldn’t start an egg until I defended my trooops, and that is when I learned it isn’t proximity that makes the hatcheries hatch eggs. The AI creates units when you attack enemy units or enemy buildings near the hatchery. Before I learned this, I tried (successfully) killing all the eggs before they hatched but I still did not get the achievement.

The first two buildings you can kill far enough from hatcheries that it doesn’t bother them… so i will ignore speaking on them.

For the 3rd building I took my full-force to the last building (instead of splitting my army 3-ways to speed-beat this)… I move-commanded my army to the building (losing plenty of forces on the way), attack command the building, link-move-command away from the building (to avoid them auto-attacking the zerg)… and flew my medivacs over the hatchery as the map was completing (for vision to ensure no eggs were made)… I completed the map successfully preventing the AI from building any units (and lost everything except my command center in the process)… and still no achievement… I did this without building any units, without mining minerals, and only using the units the map provides us with.

So… I’ve given up on trying to find a loophole in the system to obtain this achievement as I’m out of ideas. Guess we just have to wait for Blizzard to fix their mistake.

19 Likes

I am having the same issue, and it is only with this mission. “Band of Brothers” on the Gates of Hell mission, which is a very similar achievement, was awarded to me, yet I have tried the mobiues factor mission at least five times and nothing I have tried has worked.

5 Likes

What did you do differently?

1 Like

I went into the editor and found the problem. I’m not sure how I did band of brothers but the problem is the game doesn’t check for WHO is making the unit.

So when the AI enemy makes a unit, which is not an scv, medivac, or merc (so, ANY unit) it instantly blocks the achievement. AI seems to make its first unit in normal difficulty at about the 3 minute mark, so yeah no this is unachieveable.

Additionally, it appears the “hard core” achievement is also bugged, and you get it simply by finishing the mission on hard or brutal. This part I found purely by looking at the editor, so someone might need to test it to confirm.

Edit: ok, band of brothers has the condition “owner of trained unit = player one” so that’s something. There’s a chance that SPIDER MINES count against you for band of brothers, since in my successful attempt I purposely avoided them

3 Likes

Yah can confirm, using only what you start with and the units you rescue doesnt grant the achievement :frowning:

2 Likes

lol also blizz fix portraits, i will NEVER use Mira as a portrait EVER

2 Likes

Yeah i’m experiencing the same problem on these two achievements, I have tried to not create anything at all while directly flew all my buildings away at the start and only used any rescued units but the achievement just does not pop.

Band of Brothers did not pop for me either, probably because I did lay the spider mines from vultures, I even avoided dropping mules but I had totally forgotten about the damn mines, will try it again tomorrow and see if Band of Brothers works.

From what I recall, the forums are run by a 3rd party.

Just completed Band of Brothers by following conditions and not using spider mines. Rhyme’s statement appears to be correct.

-Valas

1 Like

I’m pretty sure it’s related to the fact that at the start of the mission you get 2 medivacs carrying 4 regular (non-merc) marines, which are netrual and then switch to your color / control. I think the game sees this as unit training, unlike if, for example, you would have them from the start of the game directly under your control.

Trying to use “computer-logic”, in that case, you would start with them by default, that would be the initial set-up, you should refrain from training something. As it is, they are assigned to you at some point, so… where did you get them from, if you haven’t trained them?

Not sure how the achievement is coded, but a quick-fix for it would be allowing marines to be trained… like ticking one more box (marines) of units that are allowed.

1 Like

I noticed that too. I wonder though if it won’t award the achievement because the “Action” element is missing… because the entire trigger is missing. I’ll fire up a free account and see what happens on Hard.

In the Gates of Hell mission there’s an achievement that uses the same trigger layout. In Gates of Hell, we rescue all sorts of non-mercenary units but the achievement still pops. Like Rhyme mentioned above, it seems there’s a missing line in the achievement trigger:

So it appears that if the Zerg AI makes anything, it trips the trigger and disables the achievement.

4 Likes

I can’t get either of the achievements for The Mobeius Reactor or Gates of Hell. I thought it was because I was “training” MULEs but even then I didn’t get them. Dunno what to do. Forgot I even had vultures for spider mines.

EDIT: I did a run of Gates of Hell without training ANYTHING whatsoever (no SCVs, MULEs, merc, etc…) Only supply of army came from the drop pods scattered around. And it did work. However, I tried the same thing with the Mobeius Reactor and still no achievement.

Did you rescue the drop pods and not make spider mines in the same play through? How about Mules?

I’ve built mules, spider mines, raven turrets and pdd in Gates of Hell, but still got the “Band of Brothers” achievement.

Why hasn’t it been fixed yet?
The mission is completed without any construction at all at the normal level of difficulty.
Fixing scripts should take 2 minutes. of which 1 minute is the start of the editor

3 Likes

I have tried again today a few times to see if I can finish this before the zerg build units, and the quickest I can kill all 3 buildings is 3 minutes and 11 seconds… but all of the NPC chatter ends up taking me up to 3 minutes 57 seconds before the level completes… so it does seem that if the Zerg building units cancels out the ability to complete the achievement, this seems pretty impossible.

I hope this gets patched soon. Thank you all for your input at least now we know not to waste further time attempting it.

Are you really finishing it before the AI builds any units? The hive at the 3rd data core starts making lings when you go near it which means you have to finish off the core before those complete. This makes it impossible to get the achievement as is.
You can complete the mission in less than 3:32 (that’s the time when the achievement failed for me when I did absolutely nothing, so it has to be the softest limit) including dialogue. I got a 3:30 with the achievement restrictions but since I triggered the lings, I would’ve had to win at 3:10 or something which is just not possible without making units

Edit: Meant to reply to Trosdan

I rescued all the drop pods but built 0 units or structures in the process. I did not use mines, mules, raven summons, etc. The only things I spent money on were repair and infantry weapon upgrades

Yeah it is the only one I am having trouble with.

The text of the “Band of Brothers” achievement specifies that we can build Medics, which appears to be incorrect based on this screenshot.

3 Likes