Contract Saviors Achievement Borked

I tried this one a couple times, I completed the mission (The Moebius Factor) without building a single structure or unit of my own and it still won’t unlock. Seems like this cheevo is broken.


I just gave it a try and it didn’t work for me either.



Since someone in the other thread said they attempted NOT doing any rescues and training only mercenaries, I tried the reverse. I played using ONLY initial forces plus medivacs, SCVs, and whatever units I could rescue from around the map. Didn’t even train a unit of War Pigs.

Still nothing. So it’s either completely borked, or there’s some really weird exclusionary factor they failed to mention.

It’s borked. I looked at the code in the editor and it checks for each unit built if it’s a merc, scv, medivac, or not. The problem is it doesn’t specify WHICH player it’s checking. So whenever the AI zerg decides to make a unit, the achievement gets locked off.

Hold off on this one until it’s fixed. Literally impossible as-is. “Band of brothers” on gates of hell has a similar mechanic, but that one works, provided you don’t use spider mines (I think)


omg i was going to make a post about this last night after I tried to do it 5+ times (built no units/buildings/etc)
thanks for the post and info! i thought it was just me that couldn’t do it XD

Oh well, we won’t be able to finish all the achievements until it is patched haha.

Same issue here. This achievement is definitely bugged. There are also other issues with other new campaign achievements. For example The Great Purge ticks strangely after you completed the mission even though it asks you to destroy all zerg buildings. Also Thanks For The Advice can be gained but not correctly. It says to not kill any units using the drill bur you must not even use it to destroy the temples for the bonus objective, even though the temples are not technically units.