Can't Save Games

Hi guys,

Whenever I launch StarCraft 2, it always think I’m opening it for the first time.
I would click “New Game” under campaign and it would bring me back to my progress.

If I try to Save it’ll say “Saved successfully” or something like that but when you open Load, there’d be nothing on it.

I’d appreciate any help. Thanks!

Things I’ve done:

  1. Scan and Repair (several times)
  2. Allowed Admin/Full Access of SC2
  3. Tried both launching the game in 32-bit client and 64-bit
  4. Made sure Firewall and Windows Defender was not blocking the game.
  5. Uninstalled and re-installed the game.

Hey Frakeviga,

Sorry for the late reply here. If you’re still experiencing this I have a few ideas you can try.

  1. Navigate to the Documents folder and delete the Starcraft II folder inside, then re-launch the game so it will be recreated. Progress will be re-downloaded from the server.

  2. If the first step doesn’t help, try creating a new administrator account and then launch the game from there to see if it saves properly.

Ok, I tried that, it doesn’t work.

Doesn’t work for me either.

Me either. SCII client can write to /Documents directory, so it isn’t a matter of read/write permissions. Your save function in source code just is somehow passing its check and sending us a “Save Successful” message without actually writing anything to disk. Please elevate this to your software QA team immediately.