Cannot enter lobby bug?

Hello all, I have not been here for a while, but the game has been working until today…
Whenever I try to create a custom game, it gets stuck on ‘Entering Lobby’ for long time, and then comes back with an error saying ‘there was a temporary problem with your request. please try again’,
This happens no matter which map I choose, and basically means that I cannot play a custom game at all.
I have tried closing the game, and the restarting it, but the problem remains.
Not sure if this is a bug, or a known problem with the latest patch, but would like to understand this, if someone can explain please.
I am going to try the Scan and Repair option to see if I can get this almost religiously malfunctioning game to work. I swear, I am almost sorry I paid the money for this game that messes up so much.
Afterwards, I guess I will try to reboot the computer to see if that can make this Blizzard travesty function right, but if someone could give me some information on what would cause this I would be grateful.
Thanks in advance!!

Will be good to just search through forums before creating a new post:

1 Like

Thanks Kyrie, I certainly hope they can correct this issue, because I wanted to enjoy the game I paid for, and these kind of things ruin it completely!!

Here we go again…
Are they ever going to fix this ridiculous bug, or is it just a part of the game now??
It was working yesterday, but this morning it is not allowing you to enter a lobby again.
WOW Blizzard cannot get their act together can they??
Can I request a refund for the game because of this foolishness?? Because it is broken if you’re not allowed to play because Blizz cannot seem to make a game that works anymore!!

PS. while I understand that Blizzard Entertainment only cares about what investors think nowadays, I am hopeful they will get off their collective butts, and fix their broken products. But I am not holding my breath.

For the record, I have tried everything for this issue.

  1. Scan and Repair utility for game found nothing (of course).
  2. Rebooting computer still same problem.

Can I get my money back for this travesty of a game they do not even bother to support??