fails with 100,000,000+ error messages in log

A few days ago I tried to start up SCII and it stalled on a small window that said “Downloading new files…” Today I tried two times to just let it go for more than an hour. The first time it created a 46GB log file. The second time it created a 54GB log file. It basically filled up what space was left on my laptop’s HD.

The “Starting Battle.Net…” window also took about 24 seconds to disappear before the “Downloading new files…” window. I’ve never seen that message that long before, either.

I tried downloading the app today and to install it again, but the installer just does the same thing.

I can’t play anything because I can’t start any games. Network is fine.

From the 54GB log file:

PS C:\ProgramData\\Setup\s2_2\Logs> get-content *21.log -head 1000
I 2023-03-08 05:35:21.332163 [Main] {3b2c} Launcher started.
I 2023-03-08 05:35:21.332267 [Main] {3b2c} Running from: C:\Program Files (x86)\StarCraft II\StarCraft II.exe
I 2023-03-08 05:35:21.332291 [Main] {3b2c} Configuration: locale=enUS region=EU uid=s2_enus
I 2023-03-08 05:35:21.332478 [Main] {3b2c} Embedded data found in binary:
I 2023-03-08 05:35:21.332530 [Main] {3b2c} Session hash generated. hash=15685281001404714141
D 2023-03-08 05:35:21.332756 [Analytics] {3b2c} Analytics request sent. type=BNET.BI.SessionGenerate
D 2023-03-08 05:35:21.333086 [Analytics] {3b2c} Analytics request sent. type=BNET.BI.BootstrapperSession
D 2023-03-08 05:35:21.333106 [Main] {3b2c} Entering main loop.
I 2023-03-08 05:35:21.333119 [Main] {3b2c} Bootstrapper State: STATE_CHECK_ENVIRONMENT
D 2023-03-08 05:35:21.334001 [Main] {3b2c} Checking permissions on path: C:/ProgramData/ depth=-1
D 2023-03-08 05:35:21.334923 [Main] {3b2c} Checking permissions on path: C:/ProgramData/ depth=1
D 2023-03-08 05:35:21.336870 [Main] {3b2c} Checking permissions on path: C:/ProgramData/ depth=1
D 2023-03-08 05:35:21.337303 [Main] {3b2c} Checking permissions on path: C:/ProgramData/ depth=1
D 2023-03-08 05:35:21.337702 [Main] {3b2c} Checking permissions on path: C:\ProgramData\Blizzard Entertainment depth=2
I 2023-03-08 05:35:21.339052 [Main] {3b2c} Bootstrapper State: STATE_UPDATE_BOOTSTRAPPER
I 2023-03-08 05:35:21.339070 [Main] {3b2c} Bootstrapper State: STATE_EXTRACT_AGENT
I 2023-03-08 05:35:21.339786 [Main] {3b2c} Bootstrapper State: STATE_START_AGENT
D 2023-03-08 05:35:21.339804 [BSAgentManager] {3b2c} Starting agent
I 2023-03-08 05:35:22.504704 [Main] {158c} UI State changed to: UISTATE_RUNNING_BOOTSTRAP
I 2023-03-08 05:35:22.506556 [Main] {158c} Active screen changed: bootstrap
E 2023-03-08 05:35:51.622079 [Main] {3b2c} Failed to communicate with Agent after launch, attempts=241
E 2023-03-08 05:35:51.622305 [Main] {3b2c} Agent launch exception, path=‘C:\ProgramData\\Agent\Agent.exe’ error=2
E 2023-03-08 05:35:51.622369 [BSAgentManager] {3b2c} Error reported by agent: target=agent code=2 message=
I 2023-03-08 05:35:51.622391 [Main] {3b2c} Bootstrapper State: STATE_CHECK_AGENT
I 2023-03-08 05:35:51.622470 [Main] {3b2c} Bootstrapper State: STATE_UPDATE_AGENT
I 2023-03-08 05:35:51.622484 [Main] {3b2c} Bootstrapper State: STATE_CHECK_CLIENT
E 2023-03-08 05:35:51.622553 [BSAgentManager] {3b2c} Fatal error occurred while updating: 2
E 2023-03-08 05:35:51.622610 [Main] {3b2c} Handling exception in state STATE_CHECK_CLIENT: AgentException(code=BLZBNTAGT00000002, details={filename=C:\ProgramData\\Agent\Agent.exe}
W 2023-03-08 05:35:51.622787 [Main] {3b2c} Exception converted to: BootstrapperException(code=BLZBNTBTS0000005C, details={}
I 2023-03-08 05:35:51.622816 [Main] {3b2c} Bootstrapper State: STATE_UPDATE_BOOTSTRAPPER
D 2023-03-08 05:35:51.622856 [Main] {3b2c} Checking for bootstrapper updates.
I 2023-03-08 05:35:51.622871 [Main] {3b2c} Progress zone changed to: ZONE_REPLACESETUP
I 2023-03-08 05:35:51.622897 [TactProduct] {3b2c} Fetching remote version info for bts
E 2023-03-08 05:35:51.624513 [Main] {3b2c} Network - {3b2c} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\selectsocketpollset.cpp, line 375): error connecting loopback socket: A socket operation was attempted to an unreachable network.

E 2023-03-08 05:35:51.624880 [Main] {3b2c} Network - {3b2c} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\selectsocketpollset.cpp, line 201): error in select() call: An operation was attempted on something that is not a socket.

E 2023-03-08 05:35:51.624904 [Main] {3b2c} Network - {3b2c} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\standardnetworkimpl.cpp, line 345): poll error: NET_ERR_FAILURE
E 2023-03-08 05:35:51.624931 [Main] {3b2c} Network - {3b2c} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\selectsocketpollset.cpp, line 201): error in select() call: An operation was attempted on something that is not a socket.

[Repeat 100,000,000+ times]

These are connection errors which can show up if the app is not able to connect to the patch servers. It could be due to something within your Windows connection settings causing it, or for example a firewall blocking the connection to the patch servers. Sometimes malware/viruses can modify your Windows connection settings and may prevent the app from connecting.

If you’re using a proxy or VPN connection try disconnecting from it temporarily to see if will connect.

Try resetting the network configuration in Windows 10/11:
Go to Start → Settings → Network & Internet → Network reset
Proceed with the prompts and restart the computer.

Check to make sure the Windows firewall isn’t blocking the app or Agent. You could also try just defaulting the Windows firewall.

For the large log size issue, this is unfortunately something that has happened for a while with the desktop app when it fails to connect under certain circumstances. Thankfully you were able to identify where the logs were located so you can delete them.

Hopefully one of those helps get connecting again on your system!

I had already tried disabling the VPN and switching routers. That did not work. Also, I didn’t make any changes to my network before the game just stopped working.

Windows Firewall logs do not show any dropped packets. They do show packets allowed to and

Agent.exe seems to be having some conversations with both of them. What weren’t encrypted with the * certificate I copied below. Things seem to go awry after the temporary redirect (302) to http[:]//www[.]blizzard[.]com/404 in response to the POST request to http[:]//iir[.]blizzard[.]com:3724/submit/BNET_APP. Multiple SYN requests start getting sent to nydus[.]battle[.]net, the vast majority of which never receive an SYN/ACK; occasionally there is a response, though, and when that happens, it looks like the connection is closed and then the process just starts again with more SYN requests.

Maybe this communication is normal, but it seems odd to do a redirect to a 404. The connections seem a little weird, but there is communication between my laptop and both Blizzard servers, so it’s not being blocked by any firewall.

I can’t play SCII because I can’t start the app and I can’t update the app, either. I downloaded it off the web site and tried again today and the behavior is still the same.

I guess I will also add that the behavior of launching is completely different if I just turn off my network connection. In that case, a nice window pops up and says the app can’t connect.

Here’s the traffic that wasn’t encrypted (I might have copied a couple things out of order and had to edit the HTML response and remove links to get it to post to the forum).

P.S.: Someone has registered nydus[.]battl[.]net (i.e. with the “e” missing). If that’s not Blizzard’s domain, it could be a security risk. I mistyped the domain name while I was checking its IP.

GET /agent/versions?nocache=319706920 HTTP/1.1
Host: us[.]patch[.]battle[.]net:1119
User-Agent: agent/
Accept: /

HTTP/1.1 200 OK
Server: Protocol HTTP
Content-Length: 742
Connection: close
Content-Type: application/octet-stream


seqn = 1546114


GET /agent HTTP/1.1
Host: us[.]patch[.]battle[.]net:1119
User-Agent: agent/
Accept: /

HTTP/1.1 404 Not Found
Server: Protocol HTTP
Connection: close

GET /geoip HTTP/1.1
Host: nydus[.]battle[.]net
User-Agent: Bootstrapper/
Accept: /

HTTP/1.1 204 No Content
Date: Sun, 12 Mar 2023 04:23:05 GMT
Server: Apache
X-Frame-Options: SAMEORIGIN
Cache-Control: max-age=900, private
Edge-Control: no-store
X-Geoip-Region: us
X-Geoip-Country: US

POST /submit/BNET_APP HTTP/1.1
Host: iir[.]blizzard[.]com:3724
User-Agent: Bootstrapper/
Accept: /
Content-Type: text/plain
irrh-x-proto-message-type: BNET.BI.BootstrapperSession
ir-exchange: BIAPI
Content-Length: 93

battle.net2.enUS8…@.HTTP/1.1 302 Found
Cache-Control: private
Content-Type: text/html; charset=utf-8
Location: http[:]//www[.]blizzard[.]com/404
Server: Microsoft-IIS/7.5
Date: Sun, 12 Mar 2023 04:23:51 GMT
Content-Length: 144

<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href=“http[:]//www[.]blizzard[.]com/404”>here</a>.</h2>

Still not working. I haven’t been able to sign into SCII for over a week now. Today the app actually started, but it tried to update itself and made no progress. It also didn’t log me into I decided to delete C:\ProgramData\ and run (without uninstalling the old version, which I can’t do because the uninstall fails when it can’t talk to the Blizzard servers). That creates an Agent.8151 folder, which is the same version as before.

Agent.exe makes numerous attempts to connect to and fails about 59/60 times; in other words, it connects once and then can’t connect again for a few minutes. It just sends http requests for versions, receives a reply, and then fails to do anything after that.

Just for example, here are errors in the logs. I can ping this server non-stop while these errors occur, so ICMP to this server works just fine while TCP is failing–a lot, but not always.

W 2023-03-15 03:36:15.866643 [Main] {828} Downloader - {828} WRN (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 2080): HTTP: connection timeout for ‘’
E 2023-03-15 03:36:15.866759 [Main] {828} Downloader - {828} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 392): HTTP: connection failed for host NET_CANCELED

Something happened. managed to update and started up. It also connected and logged me in. Not sure it’s fixed, but at least I was able to log in for the first time in a week.

Seems to be OK now. seems to start normally and the game plays fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.