Arcade is broken

Cannot seem to create arcade games aside from Direct Strike or Squadron Tower Defense. I’ve gotten various errors such as “There was a temporary problem with your request”, or “Global Time out error” and one or two more. I’m not the only one it seems its nearly everyone.


Yep, same problem. It’s not just limited to arcade but rather any custom game. Problem has been ongoing since last night (12/22). Was temporarily solved for a few hours this morning, but returned and has been a problem for at least the last 5 hours.

Many (20+) people in general chat / arcade chat have indicated having the same issues.



It is more general problem. We can not create custom games lobbies. Includes ladder maps, arcade maps, any maps. It says either “timeout” or “you have to upgrade your version of the game”.


Here is a Blue’s official post:


Still happening. RIP to SC2 arcade



Still happening on Dec 27, 8 PM East Time: [quote=“Toothless-11138, post:1, topic:19685”]
“There was a temporary problem with your request”,

press f to pay respects.

Problem still exists for me. I cannot load a lobby for anything I get the temporary problem error message for any lobby I try to join!

I have the same problem! RIP arcade!

1 Like

Just here to say I also have this issue.

They need to get their act together. The arcade is STILL not working properly. “There was a temporary problem with your request. Please try again.” It has been like this for about a week now.

Still not working…

Only reason I play starcraft 2 is for the custom arcade games. Guess what? Not anymore, haven’t been able to play for over a week now. This is unacceptable. Maybe because it’s free to play now it means there is no rush on fixing it? Well I paid for the game and I do expect it to work as intended and if not to be fixed asap. This is just ridiculous and it breaks my heart that starcraft has come to what I see it has become.


Really is a shame… my after work downtime is ruined. Seems like we have to upgrade to access a simple feature, when we in fact have payed for the original game? What a joke.

I have the same issue. Its also saying u need to upgrade your version wehat does that mean? i have all 3 campaigns and nova missions

does anyone know what blliz is gonna do?

When trying to create a Melee game, I get the “temporary problem” error or the “Global Time Out” error when I attempt to create the lobby. This has been happening since December 24th. There was one day where I was able to create one game, then if failed when I finished and tried to start a new game.