‘An unexpected fatal error occurred’ after 4.10.1 patch


#1

For several days, after 4.10.1 patch (I’ve skipped 4.10.0) my SC2 is crashing several seconds after pressing “Play” button. The only thing I can see is black screen (for around 1-2sec) then 'An unexpected fatal error occurred" message appears. All other Blizz games are working fine.

What I’ve done so far before raising it here:

  1. Updated drivers which can cause any issue (GPU)

  2. Turned off McAfee

  3. Tried to repair the game

  4. Reinstalling the game on different drives (sdd, hdd, external)

  5. Removing BN folder from ProgramData

  6. Change setting back to default in BN client

  7. Tried both 32 and 64 bit version.

  8. Tried to kill some background processes which might be causing the issue (mostly laptop manufacturer).

  9. Running selective startup

  10. Tried WMI repository reset

All other apps are working fine.
I have MSI GE62VR (GTX 1060) running on WIN10

Any idea what can I try next?

2 Last Report ID’s

B2EFA369-D86B-4E41-93D9-32B2B1EC6BFF

200C232B-EFCE-4467-A58D-A4D282557E02

EDIT:
dxDiag below

xhttps://pastebin.com/HiRcVJzi

PS is there another way to paste it since DxDiag exceed character limit?


#2

Hey Rakimallah,

I didn’t see anything specific in the DxDiag but it looks like you are getting Access Violation errors. Based on everything you have tried, my guess is that McAfee may be causing the problem, as it could be blocking the game from working correctly, even if it’s disabled.

I’d suggest checking for updates within McAfee and then adding SC2 as an exclusion. If none of that helps, then I’d recommend temporarily uninstalling McAfee in order to test SC2 by itself. You can always reinstall McAfee again afterwards.


#3

Makes sense. I’ve only turned off ‘real time scanning’ and ‘firewall’ for 15 min. Didn’t add sc2 to exclusion list, will try it and let you know.


#4

Hi Zenlaka.

Thanks for your idea. I’ve tried to exclude from real time scanning both SC2 and BN client. It didn’t helped, so I’ve removed McAfee. Unfortunately the problem still remains.

Any thoughts what else can be tried here?


#5

I dont know, i have the same problem since more than one week right after the 4.10.0 update.i really dont know what to do,i tried everything to play it again.i even downloaded it with my old Wings of liberty disc but it wanted me to patch it. i hope they bring out some patches like they did for mac


#6

How your error looks like?


#7

.i press play on the Battle. net app then theres a black screen and then it says ´an unexpected fatal error occurred´


#8

Rakimallah, i noticed that your cpu can not be analysed for some reason. think that is your problem. another user also suffered from that problem and could not run starcraft 2 either. your cpu is listed as N/A which is not supported.


#9

Could you see if resetting the WMI repository or a new admin account helps?


#10

Having same problem on my MAC. I reinstalled game, updated my OS system, scanned the program, and posted several fatal error codes. This is my latest one.

12A80AB6-4733-492B-BD49-9E1A083EE3FF

No fix from other suggested topics worked, or could be fathomed by anybody other than an IT expert. I even program computerized machine tools, so these suggestions seem unfathomable to a mere gamer. Looks like something on Blizzard’s end needs fixed from all the comments I see and threads now locked up. This doesn’t look like a coincidence and it seems to happen with regularity once patches are introduced. I only hope Blizzard fixes them in a more timely manner than usual. I’ve played the original Starcraft and Starcraft2 for over a decade and this seems to only get worse. Hope you can fix this promptly and wish you all the best in getting the system back and running normally.

Best Regards,

Mark


#11

Same problem here, pls fix this ASAP.

1E17DC96-1F84-4D50-8F96-96E2A563FC42


#12

you should post your dxdiag. you could always change your computer`s name temporarily.


#13

Having the same issue
A3F90BC4-DCCF-41B1-AB86-5E4BED7F1390


#14

andreasasp2 I have rather standard i7 6700HQ. It works well under all different set of applications. I wouldn’t say dxdiag is a top tier tool to diagnose, so below you can see cpu-z screenshot

xhttps://imgur.com/a/gNhw1mC

Caterpepi - yes, I’ve done it before. And I’ve done it one more time, trying different atributes. Unfortunatelly, no success.

Again, every other game/application is working all good. Suddenly on my first day of holidays (which happend for the first time from 3 years) Starcaft 2, which is my favourite game of all time stopped working :smiley: well, that was a real hex.

Maybe it’s a sign :thinking:


#15

starcraft 2 is not working optimally on the i7-6700HQ though and restricted to high. your problem however suggests some kind of driver conflict. on the other hand: your dxdiag listed your cpu as N/A which is likely the problem. it means that direct x is unable to find your cpu. direct x communicates between your hardware and games. i suggest asking microsoft customer support for help with fixing that, as they can remote control your pc.


#16

I could not start the game nor get to the log in screen today on my MAC even after your new patch. My fatal error message is:

37D6483B-7C9E-A7FD-8C258ED94575

I really thought you guys would have this fixed by now.

Regards,

Mark


#17

so post it in the mac forum and not in the pc forum.


#18

starcraft 2 is not working optimally on the i7-6700HQ though and restricted to high.

I don’t mind, since I’m usally running the game on lowest details just to achieve apm. Still, this doesn’t apply to main menu - which isn’t even loading.

on the other hand: your dxdiag listed your cpu as N/A which is likely the problem.

I really doubt this is the problem. Take a look that all other main categories are listed as N/A which is: System Manufacturer, Model or BIOS and RAM. It’s not related to CPU, it’s dxdiag/MS thing :woman_shrugging:

Seriously, this might be not even a part of the problem (why any other application is working, while it using same libraries/drivers?). And it seems it isn’t.


#19

games does not care about system manufacturer, model or bios. games only needs to know about cpu, gpu and ram. if either of them is listed as N/A the game might be unable to run.


split this topic #20

2 posts were split to a new topic: Briggsy - SC2 Crash