"Render Device Lost" Fix for RTX

It is time that Blizzard admits there is some issue instead of sending users down a path of trying a million different options that have not actually fixed the issue for anyone.

I have a RTX 2080 TI with an 8700k in my home PC that started getting this issue after updating from a 1080. Nothing is overclocked at all. I have formatted my computer, installed all of the latest updates and drivers. Disabled 3D Acceleration on everything that might utilize the GPU (browsers, etc.) No apps are creating an overlay ingame, including Geforce Experience. Closed all extra apps that are running and I constantly get these errors once or twice a night, I literally cannot do competitive because of this and I have been googling this same error for months now.

To top it off, I bought an Acer Predator 500 laptop the other night ($2500- has a i7 8750H, RTX 2080 in it) and I am now getting these same errors on the laptop.

Does Blizzard have this issue with their code documented is actively pursuing a fix?

1 Like

Last update on this thread from a blue was first week of February from what I can see.
The dev team have been looking into this since Dec if not earlier. I’d love to know what they have found so far after 3 months investigations.

1 Like

Been having this issue ever since I upgraded from my 1080 to a 2080 as well. This is the only game that ever has issues. I’m at factory gpu settings. Latest drivers. Get a device render crash almost daily.

I was at a lan party friday-saturday and had it happen 3 times. It was especially infuriating due to the fact we hit our connection cap to blizzards servers so if you crashed it took upwards of 15 minutes to log in.

This is just unacceptable.

Anyone wanna bet the computers running Overwatch League don’t have RTX cards?

Blizzard has already admitted there is an issue. But admitting there is an issue isn’t the same thing as knowing exactly what is causing the issue. Not to mention that for some people it is more than one thing causing the crashes.

Have you already tried renaming Overwatch.exe to something like OverwatchTest.exe?

It would be nice if they bothered to do a pinned post stating “Known issues with RTX cards” with a run down of temporary fixes instead of fishing everything from a 500+ post thread.

We’re still checking this out and communicating with NVidia on it, but have no updates to share at the moment, unfortunately. The quoted text is still the method players should be using to troubleshoot this issue. Rename the file and see if it works. If it doesn’t, you have a different problem most likely and should try troubleshooting it in another thread or with support. Make sure you let us know that you tried the rename method if you contact us so we don’t send you back to this thread.


3 months and still no progress between ye :confused:

I’d like to think that ‘if’ this is eventually resolved that they will actually advise what happened and how they fixed it.
Unlikely but transparency isn’t exactly a thing in these situations as no one wants to admit fault.

Ah well

1 Like

The Overwatchtest.exe fix doesn’t let me get past the Authentication stage. I get no notifications needing authentication from the app, and using the manually generated codes don’t work either.

I had this issue for 2 years, now i play MH mode only, I’m scared to play ranked.

GTX1080TI, windows 10, tried everything, i give up, now Im happy with Apex. never crash.

Have you tried resyncing the authenticator? With the renaming method you won’t get a notification but you will need to sync manually. It is possible your app is out of sync. If it isn’t that it is also possible you are filling in the wrong credentials. As your last resort you should contact Blizzard directly, not the forum, in case it is still doesn’t work even with what you may believe are the right login codes.

@Vike The issue you are experiencing is likely not related. This is an issue concerning the RTX graphics cards only. Any card can get a render device lost error with it being a rather generic error which doesn’t immediately explain why the graphics card stopped for a short moment.

This keeps happening to me as well, this is getting crazy, my LOCK OUT TIME FROM NEXT COMP GAME 2 HOURS??? and I cant join back in. This only happens when I play COMP

I’ve put the RTX 2060 back, turned off Shader Cache option in NVIDIA Control Panel and restarted the computer, after doing that I was able to play for 3 hours without any crashes or problems.


Switched from an RX 580 to RTX 2060. Now I am getting this problem. Where I didn’t have this issue before. It really seems like an issue with RTX Cards… Novideo memes are kicking in :frowning:

3 hours is not enough for testing. Sunday, i played over 8 hours and not a crash. Today i had 3 crashes already(been playing about 2 hour).

I’ve had this issue with my Strix RTX 2080 Ti. I did the admin-cmd “sfc /scannow” just in case, did a driver nuke with DDU and got a fresh driver from nvidias site. Haven’t had time to try it out, cuz work.

This is something that shouldn’t be an issue at all.

Hi same problem here, RTX 2080 maxq laptop (Asus GX701), crashes twice today, after about one to two hours of gameplay, OW just freeze and “rendering device lost” with newest nvidia driver 419.67

same bro. Mine start crashing today, twice after about 1-2 hours. RTX 2080 max-q

Same issue here: Gigabyte RTX 2080 Gaming OC and Ryzen 2700x. It started last week with a crash almost each 20 matches, now there isn’t a match I can complete without a crash. I have tried almost all fixes without success. It started when I installed 419.67 driver.

1 Like

Interesting enough, at least my problem might caused by “Turbo” mode from Asus software, in this turbo mode, graphic card will auto overclock 100MHZ, and after I turned off, for all most 4 hours continuously gaming I did not have any issue. So it could be your card also OC, just saying, at least that is what I found.

Yes, but I’ve played a total of 12 hours since installing the RTX 2060 and everything was fine until now, the game has just crashed exactly when a match was finishing and interestingly enough this is the 2nd time it crashed at that exact point.

12 hours without a crash is def an improvement but I am afraid it’s still an issue, even after disabling the Shader cache. Although it might be totally unrelated, I will keep it disabled for the moment.