Overwatch Hangs for 10+ Seconds if I Enter Options Menu

Recently, perhaps around the time the game was updated for the Reaper Dusk skin challenge, I have started experiencing a very strange problem. If I select Options from the main menu, the game freezes for about 10-11 seconds before bringing up the Options menu which at that point functions as normal. This does not happen when entering Social or Career Profile. The CPU usage at Main Menu is very low, maybe 2% or so, but during the time when I try to enter Options it doubles to 4% or 5%. If I try to task switch out, then the game window greys out and Task Manager/Windows says “Overwatch is not responding” but if I just wait the 10-11 seconds instead of ending the task, it comes back to life.

This issue is very inconvenient, since if I attempt to enter Options in game (for example, if I wish to change my mouse sensitivity or adjust a hero specific option), I can’t. Entering the Options menu when I’m in a game is likely to disconnect me from that game, and while the attempt is made to automatically reconnect me, it means I don’t want to risk playing Competitive mode at the moment.

The Scan and Repair option in the Battle.net launcher finds no errors, and I have check to ensure the Settings_v0.ini files in my Documents/Overwatch folder are not set to Read Only. I even (accidentally) reset all my options to Default, but this made no difference. All of my Windows/Nvidia drivers are up to date, and as far as I can tell my SSD which the game is installed to is not failing. This only began happening with a recent update. Is there anything else I might want to try? I can find no record of this happening for other users.

Here is what the logs record as happening whenever this temporary freeze occurs (note that the numbers by P2 and P3 are slightly different each time):

Windows Error Reporting:
+++ WER0 +++:
Fault bucket , type 0
Event Name: AppHangTransient
Response: Not available
Cab Id: 0

Problem signature:
P1: Overwatch.exe
P2: 1.71.1.31358
P3: 624f2538
P4: unknown
P5: unknown
P6: unknown
P7: unknown
P8: 
P9: 
P10:

It’s been a week and I’ve gotten no response on this, but I would like to summarize the additional troubleshooting steps I have taken over the last several days:

–run Scan and Repair on the installation. No errors found. No change.
–run full chkdsk /R on the installed game drive. No errors found. No change.
–run full chkdsk /R on the OS drive. No errors found. No change.
–uninstall game, reinstall on separate drive from where it was previously. No change.

Around this time, I realized that the majority of the Options I’m trying to access (mouse sensitivity, key binds) are not even stored on the local PC. They’re tied to your account and stored on the Blizzard server. With this in mind, I tried the following:

–turn off Windows Defender Firewall entirely. No change.
–bypass my router entirely and connect the PC directly to the modem. No change.
–having a different account log in to Battle.net and launch their Overwatch. No change.
–installing Overwatch on an entirely different non-gaming PC connected to the exact same router network and then launching with my own account credentials. THIS DID HAVE AN EFFECT. On the second, far less powerful PC, Options loaded after a 1-2 second delay. Not immediate like how all other menu choices load (Social, Career Profile, etc) but fast enough that Windows doesn’t mark Overwatch.exe as “Not Responding.”

So whatever is causing this is hardware specific. What is different about my gaming PC compared to the non-gaming PC? Both run Windows 10, both have GeForce driver 512.15, both have the same Windows Firewall settings. My gaming PC has an AMD CPU and a RTX series GPU, and the non-gaming PC has an Intel CPU and a GTX series GPU. Don’t see how that would affect a request to the server, or why the matchmaker etc. all sends/receives network data perfectly fine except for this Options menu thing.

2 Likes

I am also experiencing this. You are not alone. Only began happening recently too.

1 Like

As another bit of additional information: this same behavior is exhibited when entering the Options for the Overwatch 2 Technical Beta.

2 Likes

I am also experiencing this as well. Good to hear it’s not just me!

I have the same issue. Both on OW1 and OW2 beta. Tried with another account. Didn’t help.

Specs:
AMD Ryzen 7 3700X
Nvidia RTX 3090

Tried reinstalling overwatch, reset in game options in battle.net launcher, used ddu to completely remove gpu drivers and installed latest drivers. Nothing has worked so far.

Hey there,

This is an odd one for sure. Based on the troubleshooting that DarylSurat has tried it was narrowed down at least to only affecting specific systems, so there must be something in common either with the hardware or software which is leading to his apphang when accessing Options.

Years ago I remember there was a problem with another program causing issues clicking on the Options menu (I honestly forget the name of the program because it’s been so long).

I’d maybe suggest trying a reboot using Selective Startup which will shut down all background processes and non-Microsoft services, then see if that changes anything when trying to reproduce it.

  1. Press Windows Key+R .
  2. Type msconfig and press Enter .
  3. Select Selective startup and uncheck Load startup items .
  4. Select the Services tab.
  5. Check Hide all Microsoft services .
    Note : Skipping this step may prevent your computer from rebooting correctly.
  6. Click Disable all .
  7. Click Apply then click OK .
  8. Click Restart
1 Like

Thank you for the response. I followed the instructions provided regarding the Selective Startup and the disabling of all background processes and non-Microsoft services. Unfortunately, this has no positive or negative effect on the issue in either the live Overwatch or the Overwatch 2 Technical Beta. In both cases, the Options screen still loads after several seconds of delay such that the EXE is considered “Not Responding.”

I too have an RTX 3090 GPU like the user above, though my CPU is an AMD Ryzen 5950x (each of these individual components cost more than what it used to cost me to build entire budget to mid-range PCs…). I have 32 GB of RAM and am using Windows 10. Again, I’ve been playing Overwatch for several years without this issue surfacing. It’s only begun happening very recently, since perhaps the Code of Violence Reaper Dusk skin event in late February/early March.

1 Like

Same, I have been playing this game since 2016 there have been no problems at all.
To me, the problem only appeared ever since the 15 March update where in patch notes they had some Nvidia Reflex changes.

I have also done the same way you did diagnosing computer trying to locate the problem,
I contacted technical support earlier this month as well, but so far it was still not fixed.

Here are the methods I tried together with the support team.

  1. Resetting in-game settings
  2. Launch the game using a different account (including Overwatch Asia & China)
  3. Scan and repair the game using the blizzard launcher
  4. Reinstallation of Overwatch
  5. Run a clean reinstallation of GPU Drivers using DDU (Geforce experience and Drivers are now all latest)
  6. Update BIOS of the motherboard to the later version
  7. Remove the Overwatch folder entirely in the Documents folder.
  8. Uninstallation of potential unsupported compatibility programs such as Razer Synapse, QQ Protect, Alibaba/TaoBao, Huo rong security and the Baidu Netdisk software. (not fixing so I reinstalled them back)
  9. Closing security programs and whitelist Overwatch + Blizzard launcher in firewalls. (Including entirely off windows defender and firewall)
  10. Trying to reset the internet configs using ipconfig /renew /flushdns commands under CMD.
  11. Created a new Windows admin user and try to launch from there.
  12. Entirely deleted the Overwatch folder in documents
  13. Moved the system default documents folder to a high-speed SSD.
  14. Disabling all non-windows startup services and Selective startup.

They say there really might have a bug involved they will look into this, and here’s what their last respond to me:

Ixzal
Howdy Wang,

Game Master Ixzal here and sorry to hear that those steps didn’t help. This definitely sounds like a strange issue but hopefully the bug team will be able to investigate this further. However, we don’t have any way to provide updates or status information, and these bugs are prioritized based on severity and number of players impacted. This means that less impactful issues like momentary freezing while loading or interacting with the options menu may take longer to investigate and resolved compared to bugs that affect actual gameplay.

Definitely keep an eye on the Overwatch bug forums or patch notes for any updates or information regarding these issues though.

Best wishes!

Hey again,

We’ve gotten a few other reports of this happening, including a thread in the Bug Report forums, so it is something we’re tracking. We haven’t yet discovered if there is one specific thing that is causing the hang/freeze when opening Options, but as we collect more data hopefully we can help figure this out.

A few reports mention they were able to resolve this by uninstalling the MSI Nahimic program. If you have Nahimic installed try uninstalling it in the Windows apps list, restart the PC, and then test the Options button again.

If you don’t have Nahimic, it could possibly be related to one of the Playback/Recording devices in Windows and the way Overwatch is interacting with the devices. Here’s an idea to try:

  1. Press Windows Key+R
  2. Type mmsys.cpl and press Enter
  3. Right click your speakers or headset and select Set as Default Device. (if not already set)
  4. Right click your speakers or headset and select Set as Default Communications Device. (if not already set)
  5. For every other device right-click each of them and select Disable.
  6. Click the Recording tab
  7. Repeat steps 3, 4, and 5 for your microphone or headset
  8. After all extra devices are disabled, reset the game settings through the Battle.net app.
  9. Launch Overwatch again so it will re-detect the audio setup, then try the Options button once more.

This latest bit of advice has offered some insight into the potential issue at hand.

While I do not have MSI Nahimic, it is true that I do have a large amount of playback and recording devices connected (something like 18 playback, 13 recording when I account for the various virtual devices) such that Overwatch should only be using the default one. If I disable all of them except one, then the Options menu loads either immediately or within about a 2 second delay. If I enable them all such that only the desired is set as default (the usual configuration I’ve had for years), then the delay happens. This suggests that as of about two months ago, the game is now querying/pinging every single active audio device in the system every time I select Options, rather than the previous behavior by which it would only query whatever is marked as either a “Default Device” or a “Comms Device.”

The instantaneous response happens if my sole playback and recording device is a USB headset (an old Logitech G633, for reference). The 2 second delay happens if I’m using my usual USB mixer only with all of its inputs/outputs disabled save one of each. This particular device is a TC Helion GoXLR, which has 8 inputs and 4 outputs (some virtual, some physical). As keeping only one input/output enabled basically defeats much of the purpose of the device (it’s a somewhat common streamer hardware), I experimented with enabling more inputs/outputs. Sure enough, the more devices I enable, the longer it takes Overwatch to enter the Options menu (virtual devices may take slightly longer than physical, but I’m not 100% on that), even though I’m not even allowed to select any of these devices from within Overwatch 1 itself. You can only select between “Default Devices” and “Comms Devices” in Overwatch 1’s Options menu.

But Overwatch 2 is another story! Within the Options->Sound menu of the technical beta, there is a full drop-down for “Playback Device” which displays every single enabled playback device I have in my system, and this list is checked and populated as you click the Options menu! (I task-switched out and disabled/enabled devices before exiting/re-entering the menu to confirm this.) So now it wants to scan through my full list of devices each time I’m going into Options, and if each one takes roughly one half/one third of a second, then that’s about the same time as the game process EXE becomes frozen.

While there is not currently a similar “Recording Device” dropdown in Overwatch 2’s Options menu, might it be that within the last few patches, the main Overwatch 1 client has started to share some of the new Overwatch 2 Options menu code, but simply hidden the new fields from view to the end user? Perhaps a possible solution to float to the dev team might be to perform this enabled device query once you expand the device dropdown option itself.

1 Like

Hey sorry for the late reply, I use elgato wave link and the software which creates many virtual inputs and outputs for streaming. Could this be the problem?

Yes, that is likely the source of the problem. Disabling those virtual inputs will likely help resolve it.

Hmmm, that’s unfortunate because I use them to talk, stream, and record content. Is there a fix cooking up or will this be the only solution? I am guessing it has to do with Overwatch attempting to load all the audio devices while opening options? This was never the case and I am guessing started when the changes were made to Voice Chat that also affected some peoples mic limiting and gain.

any update on getting around this?

Just disabling the audio devices. Unfortunately, Windows makes the game verify access to each of them, so I am not sure Blizzard can do anything on their end.

There is no other game I play that causes this, and I tested this with noticable success with EVERY sound device I had enabled- including virtual audio cables.

  • PREVIOUSLY, I had a guaranteed 5 seconds, on the dot every time, load of the Options in Overwatch
  • After finding this thread, I (sadly) uninstalled my Audio Cable, and disabled devices, all of them one-by one.
  • With EVERY device I disabled caused the Options in Overwatch to load faster, noticably
  • I moved the Documents folder on my PC from my windows install on an OCZ Agility 3 to a Samsung SSD 970 EVO: Zero difference in speed.
  • Once there was only ONE sound device for recording and ONE sound device for playback, only THEN did the Overwatch “Options” load near-instantly; it still has milliseconds of lag, but barely noticable compared to a GUARANTEED 5 seconds before.

This is CONFIRMED happening in OW2 Beta.

THIS HAS TO BE FIXED. This is not something Blizzard can pass the buck on and say “You need to disable all your audio devices except one sound output and one sound input to play the game without experiencing lag opening our options menu, it’s Windows’ fault.”

How it is Windows’ fault but NO OTHER GAME causes this issue? Even if Windows makes you verify access every time, you can at least change the UI design so you only poll for changes say, once every 30 minutes, not every time the Options load- get the list when the game starts up, only access the device when its changed- SOMETHING can be done by YOUR dev team, because no other game experiences this- indie games i play have no issues loading their options, how is a 1-man developer loading audio devices faster than Blizzard?

Unbelievable to blame windows on this. :confused:

That’s an embarrassing take by a company with as much programming brains at its disposal as Blizzard- It’s 2022, people have a lot of extra sound devices. The go-to stance of your company for its lead FPS game in 2022 CANNOT be “you cant have more than 1 output/input for sound to play competitively and change options on the fly.”

It is VERY CLEARLY rooted in how Overwatch is loading or accessing the current sound devices when the Options are opened by a player… You already know where to look in the code, it’s just a matter of writing the backlog story and then adding it to the next sprint for the UI team to give a junior engineer. This should take at-most one release cycle to fix for very inexpensive talent. Please pass along to the producers these kind of “not our problems” when it’s 1. very clearly your problem 2. shameful to pass the buck on this kind of bug is unacceptable if they expect to keep the playerbase into OW2. :confused:

I don’t work at Blizzard.

No other game you play you mean.

If you think it’s a bug, post in #bug-report. Developers do not read this forum and your feedback cannot be passed on from here. However, if you post there, make it concise, and skip the comparisons and hyperbole.

Hello, fellow mixer brother! I posed this question in my thread and have come up with a solution for a three-second reduction while not affecting mixer audio. Check it out below!

To summarize, use the Win+R method and make sure you check what sources are duplicated and ARE NOT emitting any sound then be sure to DISABLE them!

"What if I use a physical and virtual mixer for audio separation? Will this affect any of the routings I have set to those devices?

UPDATE
Okay, so I looked into it and sadly have to deal with the 6-second hang time even after changing the default devices because I can’t afford to cut any of the mixers that I use for streaming and recording purposes but I want to thank you for pasting the information as to why this happens because it greatly helps me with trying to find a solution to it. I’m unsure if I need to experiment with the game’s script or if there is another way I can rummage around and fix the audio issue for the menu. I’m sure that I will find something hopefully before the OW2 full release date.

UPDATE 2
Disabled any duplicate sources in the RECORDING and PLAYBACK tabs using the WIN+R method that wasn’t playing any audio and the load time has gone from 6-seconds to 3-seconds!"

UPDATE 3
Found more duplicate or unused audio sources and managed to get my menu lag time down to 1-second!

The Mixers I use are the TC Helion Mini GoXLR and the VOICE MEETER POTATO x64 virtual mixer by VB audio. Being that I am using two and you are most likely using one that should completely resolve your loading issue while making your mixer unphased.