Just installed overwatch, won't run

I installed overwatch now (never played before) and when I click ‘play’ on the blizzard launcher it goes to a black screen for about 2 seconds and then returns me to the launcher and that’s it. I’ve tried all the fixes I’ve looked up including reinstalling and shutting down possible conflicting programmes/ antvirus etc. Nothing works. Im using windows 10 and I’m able to run COD, SC2 etc. fine, just not this. Can someone please tell me what the problem is? Tried scan and repair also not working.


Usually with that issue it’s either out of date drivers/windows or this issue if you use/used Razer products:

If you’re still having trouble after this troubleshooting, please generate a text copy of your DxDiag using these instructions. Once you have that made, open the file. Copy the code below, then copy/paste everything from that DXDiag file between the rows of tilde (~) marks where it says “DXDiag goes here.”

DXDiag goes here

If the file’s too large to submit, you can upload it to a file hosting site like pastebin and post the link in the code above instead.

1 Like

I uninstalled razer synapse and overwatch worked! hooray! But does this mean I can’t use razer synapse?? Can’t I use both on my computer? It didnt work with razer synapse 3…

Here is my Dx thing

System Information report written at: 06/21/20 13:45:27
System Name: DESKTOP-4JQ364A
[System Summary]

Item	Value	
OS Name	Microsoft Windows 10 Pro	
Version	10.0.18363 Build 18363	
Other OS Description 	Not Available	
OS Manufacturer	Microsoft Corporation	
System Name	DESKTOP-4JQ364A	
System Manufacturer	System manufacturer	
System Model	System Product Name	
System Type	x64-based PC	
Processor	Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz, 3601 Mhz, 8 Core(s), 16 Logical Processor(s)	
BIOS Version/Date	American Megatrends Inc. 1401, 26/11/2019	
SMBIOS Version	3.2	
Embedded Controller Version	255.255	
BIOS Mode	Legacy	
BaseBoard Manufacturer	ASUSTeK COMPUTER INC.	
BaseBoard Product	ROG MAXIMUS XI HERO (WI-FI)	
BaseBoard Version	Rev 1.xx	
Platform Role	Desktop	
Secure Boot State	Unsupported	
PCR7 Configuration	Binding Not Possible	
Windows Directory	C:\Windows	
System Directory	C:\Windows\system32	
Boot Device	\Device\HarddiskVolume1	
Locale	United States	
Hardware Abstraction Layer	Version = "10.0.18362.752"	
User Name	DESKTOP-4JQ364A\Ivor Bonnici	
Time Zone	GMT Daylight Time	
Installed Physical Memory (RAM)	32.0 GB	
Total Physical Memory	31.9 GB	
Available Physical Memory	23.0 GB	
Total Virtual Memory	36.7 GB	
Available Virtual Memory	25.2 GB	
Page File Space	4.75 GB	
Page File	C:\pagefile.sys	
Kernel DMA Protection	Off	
Virtualization-based security	Not enabled	
Device Encryption Support	Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable	
Hyper-V - VM Monitor Mode Extensions	Yes	
Hyper-V - Second Level Address Translation Extensions	Yes	
Hyper-V - Virtualization Enabled in Firmware	No	
Hyper-V - Data Execution Protection	Yes	

[Hardware Resources]


Heya Kane!

The updated versions should contain the fixed version of the software that does not have this same issue. If the problem is resolved it should be safe to reinstall the updated version.


I have razer synapse 3 and i still got the black screen. But after reinstalling razer synapse 3 it worked :slight_smile: