Game freezing with Intel i3 / Dual core CPUs

i play almost 3 hours with those commands line --tank_WorkerThreadCount 2 -thread 2 , works for now i need to test more tomorrow i have a pentium g4560 59 fps sometimes drops because of 2 cores

Since I have 2cores 4threads I’m supposed to use “–tank_WorkerThreadCount 4 -thread 4” and not “–tank_WorkerThreadCount 2 -thread 2” , right?

steam have recently launched namco gundam evolution which is a team based role shoot with tanks healer and dps roles.

its mixed reviews but overwatch fans have been given it a try or aleast more open to that format.

still crashing, not working at all thanks god i didnt paid to play this

I think I have 4 thread but I used the “2” version but you could try both

early next week is a joke, blizzard clearly don’t care enough about the issue or it would’ve been fixed already, the issues been around since the beta, yet still unresolved, somehow people in this forum have come up with a solution, when blizzard can’t even do that


i am a laptop user too.
i havent logged in this morning to try the new update but this is similar to

i5 6267U
2 c/4t my cache is only 4mb
the 8gb sodimm probably isnt helping
quadro m600m 2gb

in task manager even with 2 threads it looks to be cpu3 thermal throttle to be the profile on cpu3 for 100% utilisation

did you post a dxdiag

have u tried to lock the game to 59 fps?

oh super intreting you actually wrote the os

a win11 user. that spec is old how did you get past the tpm to install win 11. side question.

more to the point in windows 10 game mode overwatch wasnt added to me by default because it sits behind battle launcher.
i DID THIS SOME TIME AGO. like ow1 time ago

to check to see if overwatch.exe. is a acknowledged game
load game
win+g and windows game bar will open
select the cog on the right in that general tab you may have two tick boxes the lower should say
“remmeber overwatch,exe is a game” option

if you dont see it it is recognised as a game for windows game mode

oh currently game mode on or off doesnt help my freeezing issues

i have the fix sort off i mean it works for me cuz ive been playing for hours without crashing
i have intel pentium g6400 4.00ghz lmk if u guys need help

ah a fellow brother you also sold your soul ?

What wonders have you done, my brethren?

pasted this on the game launch options:
–tank_WorkerThreadCount 4 -d3d11
i did few games without crashing while before it would crash almost istantly in game.
i have an i3 6100 and rx550gpu
fps capped at 14x and hyperthreading not disabled

edit: dont know why isnt not showing but the paste start with 2 -


Today I tried switching the “-threads 2” (lasted no more than 5 matches) with “–tank_WorkerThreadCount 2” and it froze during the second match. Then I tried “–tank_WorkerThreadCount 4” and I’ve played 7 in a row and didn’t get any freezes, but I closed the game just in case (to “refresh the counter” in case it would still freeze).

I’ve experienced frame drops in the situations that, I believe, where what caused the freezes before. Like a teamfight with too many effects going on. Otherwise, the framerate is normal.

Someone mentioned before that the “-threads 2” might actually not even be a valid argument. If that’s so, then what worked for me was disabling dynamic render scale.

1 Like

I can play more than 10 games without any issue by uninstalling VALORANT because I’m guessing that VANGUARD is the root cause of Overwatch 2 being freeze in the mid game.

Not really, I had never installed Valorant in my pc and it freeze anyway. I highly doubt that’s the issue here. Maybe you are reporting another type of glitch?

1 Like

I’m sorry, I can’t really help you with that. “–tank_WorkerThreadCount 2 -threads 2” and –“tank_WorkerThreadCount 4 -threads 4” are not working for me but I don’t know why it works when I uninstall VALORANT. Btw I’m using i3-8100.

Personally, this ““–tank_WorkerThreadCount 2” is the best solution for now. While sometimes fps drops, but this is close to playable until they fix the issue

i was able to play 4 games without freeze
what I did is I opened up GeForce experience go to home tab then chose overwatch 2
and then press optimize also disable amd fsr also try limiting fps to 30
before using this fix I wasn’t able to play 1 game
this is the best solution to wait for a fix