Game freezing with Intel i3 / Dual core CPUs

its not working for me in training room its taking longer but it does crash.
—tank_WorkerThreadCount 2
-threads 2

-threads 2 looks more similar on cpu3 to that of cpu0 but on --tank cpu3 throttles i think but i am on a laptop,
will try later

I have the exact same specs as you, if the mainetance doesn’t solve anything i will try it

Doesn’t work for me either, it’s weird as i was able to play the game just fine before but it started to freeze as soon as the music starts playing

maintnace time updated it

I tried it and it’s working for me for 2 hours and without any crashes, it has FPS drops to 20 but it doesn’t crash.  and

My game freezes on old and new maps, practice range too. :frowning:

for me it crashes and freeze if i shot and move the camera real fast in range …but it on me because I only have intel HD graphics, the sad part tho is …I used to play OW1 just fine with 45fps on low.

My problem was Overwatch 2 spiking to 100% cpu usage then freezing until I end task the game. Sometimes even requiring a full restart, which was frustrating.

Doing the three steps plus the command line argument eliminated the issue for me.

--tank_WorkerThreadCount 2

No performance drop or whatsoever even after cranking up the graphics, running stable 59 FPS and running other applications to try and reach 100% cpu once again and nothing happened.
(Tested both practice range and 10 quick matches)

Kudos to you friend! Now I can finally play OW2 without worries.


GTX 1050 Ti
8gb RAM

how and where should run this code?

-tank_WorkerThreadCount 4

I tried to put everything the same as much as I could and I tested it for 2 hours, I didn’t have the problem anymore. (I didn’t test it in the practice range)
I’d say it solved it for me for now and even the game feels smoother.

Actually just noticed that --tank_WorkerThreadCount 4 instead of --tank_WorkerThreadCount 2 works aswell, despite my CPU having 2 cores 4 threads.
It makes no sense to me, unless I’m misunderstanding the command. It might help debugging though.
At least I can try the game, until a fix is released to let me play more smoothly.

what code did you use?

I have an i3 with 2 cores, I used the
–tank_WorkerThreadCount 2 and -thread 2
–tank_WorkerThreadCount 4 didn’t work for me.

Hi, where do I go to input this? New to tech talk.

–tank_WorkerThreadCount 2

Open blizzard and click the gear icon next to the “Play” button then click “Game settings” and tick the “Additional command line arguments”, paste it in then press done


I’ll go give it a try asap :sob:

maintenance delayed it for 1 hour to 9:30 PDT

1 Like

yesCan you explain how you did it and where you entered this command --Number of threads tank_Worker 2-thread 2

Servers are back. Did they fix it?