FPS drop when connected to external monitor


#1

I recently bought a Surface Book 2 13.5’ for uni and the occasional gaming. I really only play Overwatch and I have been suffering major FPS issues. I connect my laptop to a external monitor AOC U2879VF via a USB-C to HDMI adapter. It has a 1050 GTX and i7-8650U CPU. I have a fan blowing onto the back of the laptop (on the Windows logo) and charger plugged in with the slider at ‘Best Performance’ when I play.

When I play on the laptop monitor, on 1920x1080 75% render and all settings on low/off with 300 FPS cap, I easily get above 100 FPS. GPU usage hits 99% and CPU hits around ~65% with both hovering around mid 50°C.

However, when I connect to my external monitor my FPS decreases dramatically with the same settings. The GPU hits 99% but then decreases to <50°C and CPU decreases to around 20% and <50°C. My FPS drops to <50.

I do not understand why there is a major decrease in performance when I am connected to the external monitor compared to the laptop monitor. I use MSI Afterburner to monitor these % and °C. The integrated graphics aren’t being used when connected to the external monitor since the % usage stays the same. I’ve searched for this problem with other users and I haven’t found anyone with the same issue as me.

I have tried many potential fixes like disabling HEPT, setting OW to use NVIDIA GPU in NVIDIA control panel, ticking ‘Disable full-screen optimisations’ in OW properties and deleting the OW ‘Settings_v0’ in OW folder. I use Driver Easy to check for updates and my NVIDIA GPU driver is up to date. I am truly stuck, please help.


(Nathardrick ) #2

Hi there kdy,

I know this performance hit is no fun, you just want to play the game on an external monitor on this mobile computer. Right now, we know of the issue and hope to have a fix in the future. I have no information regarding that though, all I have to offer is a workaround we offer for users who want to use this type of setup.

The issue is with graphics switching when using an external monitor on a laptop that has a dedicated Nvida GPU.

  • The Workaround we have:
  • Press Windows + P
  • Select the Monitor you wish to play the game on as the only monitor
  • Launch the game
  • Press Windows + P
  • Select Extend

This should get things working for you my friend!

/Nathardrick


#3

Hi Nathardrick,

Thanks for your reply. I have tried your workaround however I am still experiencing the same performance issues. Are there any other potential fixes available


#5

Any way you can try a full HDMI->HDMI cord? It could be an error with the conversion of data from GPU to USB to HDMI again

If that doesn’t work or isn’t possible, let’s check to see what your PC is actually doing during the performance issues. Grab hwmonitor and play a game until it crashes. Once it does, check the “max” column of your test for CPU/GPU overheating. If those are getting too hot, clean the PC and take it to a PC tech if that doesn’t fix the overheating - that’d probably mean some of the heat hardware needs maintenance or replacement.

If you don’t see anything, let’s snag some screenshots:

  1. Maximize the HWMonitor window and expand all the nodes on the left
  2. Scroll all the way up
  3. Take a screenshot with the Print Screen (prtscn) key
  4. Open up the program Paint and press ctrl+v to paste in the test
  5. Crop the screen if you want to only show the test, then save it as Test1.JPG
  6. Scroll all the way down, then repeat steps 3-5.
  7. Upload them somewhere like imgur and link us to the results. We’ll use those to look for more options.

If you get link errors, just link it between two ` marks, it’ll break the link and let you post it.

looks like this


#6

Along with the previous response, please also try lowering your Desktop resolution. Going from 1920x1080 to a 4K display can cause a huge hit in performance even if the game itself is not set to that resolution. And so I’d want to try lowering the Desktop resolution to see if this helps the frame rate at all.


#7

Apologies for the delay in replies. I lowered the resolution of the external monitor to 1920x1080 however still experienced the same performance issues.

Here are the screenshots taken, testing OW on the normal laptop monitor vs external monitor. https://imgur.com/a/cGuOhG6

Edit: I just wanted to include that I also play Fortnite and Apex Legends on the external monitor and only OW gives me this issue.


#8

kdy,

Other than your CPU getting a little toasty and there being a solid overclock on your GPU, I’m not seeing much. However, I’m curious if the problem is that you’re not using the correct GPU at all while connected to the external monitor. Let’s try resetting your video driver settings, then yourgame settings, then do this:

  1. Right click your desktop and click Nvidia Control Panel
  2. Go to the Program Settings tab and select your Overwatch entry (if there isn’t one, browse for it and add it)
  3. For the CUDA - GPUs setting, force it to use your GTX 1050
  4. Now, go to the menu on the left and choose Configure Surround, PhysX
  5. For the PhysX settings dropdown, set this to use the GTX 1050 as well.

Now, repeat Nathardrick’s steps. Any luck that way? If not, did you ever swap to an HDMI->HDMI cable?


#9

Hi Drakuloth, I did everything you mentioned but still no improvement in performance. As for the cable, I have to use a USB-C adapter since the Surface Book 2 doesn’t have a HDMI slot, only USB slots.


#10

kdy,

If that’s the case, there’s likely not much else we can do here. Any time you use an adapter that translates one type of signal to another there’s a chance of quality loss - especially with some of the lower end adapters. You might be able to test a different cable of a higher quality to see if it improves, but we don’t support these adapters. Doing so would just be something you can try if you choose to, and you may need to play the game on your main monitor if you’d like to avoid the FPS drops.


#11

Hi there,

I had the same issue. The reason is that when Surface Book 2 is docked or connected to an external monitor, it doesn’t necessarily automatically turn off the screen even when you have specified Windows to output everything to external monitor. This causes excessive heat and throttling, leading to fps drops.

The resolution is to have your Surface Book 2’s monitor open just like as if you were using it, set Windows to output everything to external monitor, and you will no longer see the FPS drops. You will also notice that your Book 2 is now a lot cooler.


Has there been a single case of someone solving their "Rendering device lost" issues?
Overwatch frame drops from 60 to 10 when external monitor is installed
#12

Running in a similar problem having low fps with external monitor on laptop. This actually worked but I don’t want to do it every time.
Anyone have an idea how to let the monitor use the dedicated GPU or something like that?

Edited by Blizzard - this topic is being locked as this is an old post which was bumped. Please create your own thread or contact support.


closed #13