Crash on Launch

Latest update caused it, drivers are updated and ran the repair. Nothing, can’t play the game, was able to play it before the update.

Can’t find any applicable solutions in the Forums.

Same of me too unfortunately.

Same issue here. Tried reinstalling, updating, repairing, checking drivers, and every other little thing I could think of. Still can’t run the game.

If you’re having issues launching the game, make sure to review the common causes for this behavior pinned at the top of the forum.

OP: Please include your DxDiag.

Everyone else: Please make new threads with your own DxDiag.

Please explain it to me like I’m 90 years old trying to figure out a Tablet.

Also, this has not been an issue until the update. I have been able to play the game without issues UNTIL the latest update. As stated previously, the older fixes are not fixing the problem.

Explain what to you? How to run a DxDiag?

Click here to show/hide DxDiag instructions
  1. Press Windows Key + R, then type DxDiag and press Enter.
  2. In the DxDiag window, click Save All Information.
  3. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message DO NOT shorten it. Instead, post it on and provide the link to it, or the hash code (the numbers/letters after the .com) in your reply.

As for what changed, probably a Windows update interfering with something like peripheral drivers, drive management software, or security apps. But I can confirm there is no known issue with launching the game. I’m also a player like you and I haven’t run into this.

I tried booting into Windows 7 and the game worked. Going back to Win 10, it still crashed at launch.

I went and uninstalled something called Razer Chroma something or other when looked at installed programs. I’m assuming was installed with Razer synapse but wasn’t removed with it when I uninstalled synapse a while back.

So maybe check under your installed programs and clear that one out too.

Razer’s programs don’t play nice with Overwatch and vice versa in general. No real solution to keep them working smoothing with one another other than removing one or the other from your PC.

Yup, uninstalling Chroma did the trick.

Think I’m done with Razer products, all they seem to do is interfere with everything else I have installed.