Won't let me open the game

I have tried all the methods to open the game, re-install it, repair it, update my driver, and other stuff. Nothing seems to work.

any subjection?

Hey MrCow,

When the game does not open when pressing play typically it is crashing at the startup. Let’s go ahead and get a ticket placed with our technical reps so they can take a look at what may be going on. You are going to want to include a list of all troubleshooting you’ve done on your own as well as system files and a screenshot of any error messages if you get them.

been having the same issue ever since I built my new pc

A common reason for the game not launching (especially on new computers or fresh installs of Windows) is OneDrive conflicting with the Heroes of the Storm client. If OneDrive is set up to sync your Documents folder this will cause the game to crash on launch.

To work around the problem, unsync the Documents folder in OneDrive settings. If you’re unsure of how to change which folders are synced in OneDrive check out the info here:

https://support.office.com/en-us/article/choose-which-onedrive-folders-to-sync-to-your-computer-98b8b011-8b94-419b-aa95-a14ff2415e85

Hey guys! It is happening to me as well, after the windows update. Worked as a charm before. All other apps are running OK, OneDrive is not part of my PC, I checked even the process/daemon (is turned off). Checked also Gdrive for same possible issue, no luck. Any ideas what to do? I cannot turn on the game for a week now .

Having the same issue… After a Windows update my HotS start to crash. And now I can’t open it.

I tried some stuff like update my GPU driver, and other but didn’t work.

Need some help!!

Edit 1:
I had found the problem. One software called: “OFD Topaz” was installed in my computer. When I remove it, my HotS begins to work well again!!!

literally just uninstall one drive if you don’t use it. it fixed every single on of my problems.