Visual bugs since latest patch

In case it helps anyone else, i was having this issue running all graphics settings on low. I changed shaders to medium while keeping everything else the same and so far havent experienced the issue yet. Will continue to see if this has resolved it for now.

UPDATE: Spoke too soon, just saw a minor case of this today. It doesn’t seem to be in as many areas as before but still there.

1 Like

Same here:
MacBook Pro 2017
AMD Radeon Pro 560 4 gig of RAM
MacOS Mojave 10.14.6

Same.
MacBook Pro 2015
Intel Iris Pro 1536 МБ
MacOS Mojave 10.14.6

I hope the problem is solved soon.

Thank you all for providing the details, added you all to our tracking as well! Nothing new as of yet. We’ll continue to update as new information is available!

It seems that it’s a hit or miss with setting the Shaders to medium seems to help a little bit. The issue continues to happen, but it may be something to get the game to a bit more of a playable state in the mean time.

Please continue to provide the Mac Model, Integrated/Switchable Graphics/External GPU that is being used, as well as the OS version.

If you do have a switchable graphics available, does going to System Preferences > Energy Saving and unchecking Automatic graphic switching help at all or just a bit?

Exactly, I tried to lower video setting and it did not work. the visual bug still remained. and I do not know if blizzard would fix or not cuz it has been already 2weeks. Although Blizzard got the same issue from mac users many times, all they are doing is to keep asking the spec of your computer and OS. It is so disappointing situation as a blizzard fan. Please stop asking spec (you guys already know) and fix it asap.

Hey there, folks! An update, our team is aware of the issue and have found this to be a consistent issue. There’s been some experience with this being worse in Catalina for those who haven’t updated yet. At the moment, there’s no exact timeframe on when this may resolved and it may take some time for this to be resolved due to the complex nature of the issue causing the visual bugs.

Setting the Shader setting to Medium may help reduce the issue slightly, but the issue with the visual bugs will still be present.

Our team is fully aware of and working on a resolution as quickly as possible. I hope that we’ll have more information on this soon soon. For now, we’ll continue to monitor and update as we have more information available.

Thank you for your understanding and patience with the issue!

1 Like

Really appreciate the quick updates and communication. Will be happy to provide additional feedback on any patches aimed towards fixing this issue.

Thanks for looking into this!

Same issue, battle of eternity is the most bugged map

macOS High Sierra
version 10.13.6
Processor 2,7GHz intel core i5
grafics intel iris pro 1536mb

MacBook Air (13-inch, Early 2014)
macOS Catalina
10.15
1,4 GHz Intel Core i5
Intel HD Graphics 5000 1536 МБ

Same here…
Macbook Pro (Retina, 13-inch, Late 13)
2.4 GHz Intel Core i5
8gb Ram
Intel Iris 1536 mb

Turned shading to medium and nothing. Honestly this has been a known problem since the patch to support metal. If you’re not going to fix it just say so. I don’t understand the change anyway. Blizzard has clearly pulled a lot of support from the game and this patch just cut the legs out of the already dwindling player base.

1 Like

does anyone know of a temporary fix for this?? pretty much had to stop playing because I was throwing games when team fights ended up in the bad spots of certain maps. LoL and DOTA 2 both have issues on a lot of Macs right now too so it’s not like I can just start learning a new moba

1 Like

On certain maps I tend to restart the game at the the 22nd second before the match starts, because I had the feeling, a part of the problem was the buildings building themselves up. It actually made some of the “problem maps” playable. Hanamura for example, I was basically blind around the objective moving, until I restarted, then it worked…but the sound gets messed up somehow after the restart. One of the worst maps is Blackhearts Bay, the bottom lane is extremely messed up and not playable at all, even after restart. I hope that information helps a bit for whatever reason. Using a MacBook Pro Retina 13’ mid 2014

2 Likes

macOS Catalina
10.15
iMac (Retina 5K, 27-inch, 2019)
3.6 GHz 8-Core Intel Core i9
32 GB 2667 MHz DDR4
Radeon Pro Vega 48 8 GB

It seems that setting Shaders to Medium helped. But I’d prefer a permanent fix

We’re actively looking into this as much as possible. This will take some time to fully resolve as we may need to communicate with other parties on the graphical issue. No official updates as of yet, but I’m tracking this closely!

Some of you have reported that the Shader set to Medium helps a bit that can be used as a workaround to have the game in a more playable state. An unsupported workaround that may be a better alternative for some, is bootcamp or VM. This is not ideal and not something that we recommend, but it may help in the meantime for those who would prefer this instead.

I’ll continue to update when we have more information. It may be a bit of time because of the complexity of potential driver or graphics API issues that our team is investigating. Thank you for your patience!

Macbook Pro 13 inch mid 2012
mojave 10.14.6
2,9 Ghz intel core i7
16gb MHz DDR3

I have fund a way to get around it. When ever I see a glitch in the beginning of a match, I quit hots complete, and reopen it. You miss the beginning of the match, but when you enter, no more glitches in the rest of the game. So worth it in my opinion.

BUT the trick didn’t work on blacks heartbay. glitches through the hole game on that map, even when rejoining the game after complete quit…

1 Like

Well I tried that, didn’t work. Took me 8 minutes to reopen the game, plus 5 to reconnect, and nothing. Same bug, same glitches, Hanamura Temple totally fu… up. Tried some Braxis too, impossible to play in that bot lane. Man, this killing me. I almost uninstalled HotS today…

1 Like

Changing the shader doesn’t work. Getting frustrated by losing quite a few storm league games due to not being able to see what’s going on. Try dodging a stitches hook when you can’t see yourself, stitches, or the hook. Volskaya turret camps, bot forts/keeps, mid keeps, and core areas are unplayable.

3 Likes

lol do you guys know that blizzard just tries to drag time?
keep asking computer spec and it seems obvious and its been 3weeks and even after last patch, it wasnt fixed it at all. thesedays blizzard going in wrong direction. after release diablo mobile, I feel they are falling down so fast. I want blizzard to realize whats going on…

From a big fan (from warcraft1)

1 Like

LOL… and the next fix given is to get third party software so you can run HOTs on Windows while on your mac. Oy! Blizzard was a great company once upon a time.