Unable to move cursor in game (Workaround)


#43

Hi, I am also playing on a mac and am having this same issue. When windowed, one issue I’m still having is that the camera view will not backtrack to the left, so while in game this causes serious issues when in a tight spot, as I cannot move left on the map and retreat. This issue has been going on for me for days now, since last update. I cannot play until this is fixed :slightly_frowning_face:


#44

Hi there, I’m playing on a Mac and have the same issue with the mouse not able to be moved on anything but standard windowed view. Just updated heroes today, and it worked fine yesterday before the update. I’m currently on:
Mojave v 10.14.2

I tried the workaround, but blizzard is already selected for accessibility.
Would appreciate if you could help resolve this!


#45

re-select it thats the key


#46

This solved the problem for me, thank you!


#47

Hello, my mouse control doesn’t work in full screen on macOS Mojave 10.14.2
I’m sooo sad, I get new gaming mouse for christmas and after 1.12.2019 i need go back to work.

happy new year to all


#48

My cursor is still not working properly in fullscreen. I tried uninstalling and reinstalling. I did the Privacy Accessibility setting. The cursor is working fine with under Window(fullscreen) mode now. It can move in fullscreen mode, but it stutters a lot. Looks like there’s something wrong with the Cursor Confine…where is the fix???


#49

I used this tip and it got the mouse movement generally working again. However, for higher level players, you’ll likely notice that it’s near impossible to play with precision. The cursor has intermittent delays is the closest I can explain it. It’s like playing on a Display with a refresh rate that is sometimes fast and sometimes 30Hz. I purchased a new Logictech Pro gaming mouse and mouse pad – didn’t help. Please fix!! The game is not playable for higher level players on a Mac anymore.


#50

Same issue here, Starcraft 2 on 2018 MacBook Pro on OSX Mojave 10.14.2. Playing with Metal API set.

No combination of mouse, window/fullscreen, cursor locking, or other settings fixes it so far; enabling SC2 in the Privacy settings doesn’t work either (also tried restarting after setting that, no dice).

I think it might have something to do with the middle-click-to-pan function. I’ve only tried briefly, but it seems like the problem doesn’t start showing up until after I’ve begun to move the map around with the middle click. Until then it works perfectly the couple times I checked.

Even if it doesn’t trigger so long as I don’t middle-click, middle-clicking to pan the map is something I make pretty heavy use of, so the game isn’t really playable on MacOS for me until this is fixed.


#51

You said to use command + M . What sis command? its not a keyboard touch. i Cant right click to anything in game and i cant go to my option , command is unclear to em to solve this problem.


#52

Hey all,

Sorry for the silence on this one, it looks like we missed giving you a follow up on the situation a few months ago when this was fixed. We actually worked with Apple on this problem, and it’s been resolved in Mac OS 10.14.4

If you have not upgraded to 10.14.4 or later, please do so. The fix is not retroactive for earlier versions of Mac OS so you will need to update to resolve the problem.