Unable to move cursor in game (Workaround)


#22

I will add another +1 to this. As a software developer myself, this is very disappointing to see, as the patch was clearly not tested on any Mac machine with the latest OS.

The workaround posted of allowing HotS/Battlenet to control my computer did work so far, but I’m not comfortable with that as a long-term fix.


#23

10.14.1 Mojave here on an iMac Pro & windowed works, neither full screen works.
The initial "window’ is tiny & I have to stretch it out from the edges, but then it’s fine.


#24

I was able to get my mouse by following the work around.

I went to System Preferences > Security & Privacy > Privacy > Accessibility and then I clicked the lock at the bottom left to unlock the settings (type password). Then I clicked the checkbox next to SC2.app. Then relaunched SC2 and it fixed my issue.


#25

this worked for me too!


#26

This solved the issue. You guys need to pin this to the top.


#27

No they need to fix this. How many casual players were lost due to this because they don’t go to a forum looking for a fix? How often will people try to open a support ticket for this and just give up? (they can’t because “a f2p game has limited support”.)

With all the crashing and poor performance and bugs the mac playerbase is swindling and blizzard will point their fingers at apple and their low marketshare.


#28

Hello I have found a solution to the current mac issue, if you could pass the information on it would be helpful for other players. The mouse can not be moved. The solution is; 1. When in game and it dose not move press command + M 2. You will now bein a windowed mode where the mouse can-move. Go into OPTIONS and click on “mouse and keyboard” then on the left “confine mouse curser” and turne it OFF 3. Now you can change the graphics back to fullscreen and it will work Hope that helps


#29

I also have this problem. I am running macOS Mojave 10.14.1.


#30

I am also having this issue . i have uninstalled and re installed the game to no success. Restarted my computer and reset my NVRAM and issue persists. can we get an update to fix this issue please? I am currently running Mojave10.14.1. Game was working prior to me updating then my cursor stopped functioning in game, with my built in mouse or my bluetooth mouse.


#31

this works for the mouse, but I found that my chat button has also been affected and doesn’t work now


#32

That’s an asinine fix. I’m just not going to play for a few days, I guess.

Turning the confine cursor setting to Off doesn’t work, by the way. Although, I did notice that turning the setting to “On” meant that I couldn’t even move it even in Windowed mode.

Just remove the cursor restriction. Nobody should be playing in windowed mode anyway.


#34

With the latest updates to the games the mouse cursor in SC2 and HotS stopped working in fullscreen mode. In D3 the cursor was laggy. After applying the " System Preferences -> Security & Privacy -> Privacy -> Accessibility" workaround to SC2, HotS, and D3 the mouse cursor works just fine in fullscreen mode.

Switching the game to Windowed or Windowed(Fullscreen) modes also fixed the cursor issues.

StarCraft v.1.22.1.4843
StarCraft II v.4.7.0.70154
Heroes of the Storm v.2.40.0.70200
Diablo III v.2.6.1.51663
Hearthstone v.12.4.0.27641

MacBook Pro (Retina, Mid 2012)
2.7 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel HD Graphics 4000 1536 MB
macOS Mojave v.10.14.1


#35

Performing the steps to add HotS to the Accessibility list corrected the problem for me.


#36

Thanks. This fixed my issue.


#37

This worked! Thank you! Thank you! Thank you! Was getting SO frustrating!


#38

Thanks you saved me :smiley:


#39

The Privacy settings worked perfectly for me. I am on the latest version of Mojave. Enabled the SCII and HotS. Mouse is working in full screen for me now. Thanks!


#40

This needs a quick fix Blizzard. My son and I love playing our Blizzard games. But this kind of quality control is dissapointing. This needs to be fixed in hours. This is affecting almost the whole community of Mac users. The workarounds are not tennable. Come on!


#41

Same for me. am no longer able to move the cursor in game.
Impossible de bouger la souris dans le jeu.
Je suis lvl 619 … je joue tout les jours depuis la beta …
Merci de régler rapidement le probléme on va rater tout l’event de noel …


#42

issue resolved by giving permission, ty