Stuck on "Preparing game data"

Is there a new way to make it run faster? Last post I saw on it was on 2020

Hey there,

I know there have been situations in the past that could result getting caught in a stalled update, but those were due to specific issues that were resolved at that time. We aren’t seeing any other reports about this at this time (Though that doesn’t mean there can’t be an issue.) So whatever is happening is likely local to the client, system or connection.

I have some things you can try. The easiest but one that takes a bit of time. Is to leave it on that screen … give it a significant amount of time, like upwards of 4 or 5 hours. It can possibly just be hung up on something and if so, eventually resolve itself.

We can also try a few things with the client, system and network to see if we can’t get it to update properly.

Try doing a power cycle on your system. Turn off all devices including the modem. Wait 60 seconds, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

Let’s manually clear the Battlenet Desktop Application and all supporting data from the system. This will not remove existing game clients.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.

Try running your system in selective startup mode: https://battle.net/support/article/200483

Create a new administrator account: Blizzard Support - Creating a New Administrator Account

Once the account is created, shut down the computer, wait 60 seconds, restart, log into the new profile and try the app/client.

If that doesn’t solve the issue, then I recommend submitting a ticket with an msinfo attached for further investigation. (instructions for collecting that msinfo report will be on the form.)

Click your name at the top right of this page, click support, click contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.