[Main Thread] Log in as administrator / Update loop

Keeps downloading when I open or close HotS.

Fixed for Me
Ok This worked for me dudes. I hope it Helps Some of You. GL HF

I moved all the contents of the Documents File Of Windows to another place.
I think to delete or erase the Heroes of the storm folder there should do the trick too. But for safe I moved the Entire folder somewhere else.
Somehow That was the trouble for me.
Once I Cleared that Documents Folder I was able to install.
I think it has something to do with One Drive Settings Sync of that folder.

5 Likes

Thanks dude, it helped me.

:ok_hand:

Change owner of ‘%Documents%\Heroes of the Storm’ and all subfolders and files and take full access to this folder and all subfolders and file - FIXED PROBLEM for me

3 Likes

solution posted here doesnt work for me. This patching issue has been going on for weeks now and causes my games FPS in HOTS to drop very low making it hard to play. If this is affecting the entire bnet launcher how has it not been fixed yet

3 Likes

I am here to say I have this issues too, and the fix did NOT work… its EVERY time i load the game…

when i run heros of the storm its updating everytime any solution to remove that issue?

2 Likes

Mine keeps updating also, been doing this for over a week now. I have tried the suggested fix from a different post and it still did not work. But I guess it isn’t a serious enough issue to warrant any attention.

1 Like

It’s not just HOTS. It’s all games on the Blizzard launcher. It’s been talked about a few times but besides being ‘acknowledged’ in a twitter post, it’s been complete radio silence from blizzard overall.

1 Like

Still getting the update of 137mb EVERYTIME i load the launcher… The “fix” from blue posts does NOT work for everyone. Please FIX your launcher…

We shouldn’t have to do all this special stuff… I know you guys are having a lot of conflict… but please… make your games work properly… people like me with slow internet suffer from this…

2 Likes

Sc2 does NOT do this too me…

but HOTS requires 137mb EVERYTIME… Not sure why its like this… Its definitely on Blizzards end! and they need to FIX IT

2 Likes

Daily “It’s still not fixed” post

2 Likes

This worked for me but I only found this comment on a post by accident after days of searching. Why isn’t this stickied on the front page? Seriously… blizzard support is so bad. Also, how did blizzard F-up the installer for all their games?

Daily reminder that the blue post fix doesn’t work for a LOT of us…

Fix your installer

BUMP

2 Likes

it’s already activated this isn’t a solution to problem. i am still having fps and ping issues along with a daily update of al games

2 Likes

Agreed. Last time I tried to play I had MASSIVE input delay and constant stutterings.

I can delete replays now, but the constant patch loop issue remains.

1 Like

This problem did not exist 2 months ago can they just patch it ?!

This didn’t help me, it was already checked

2 Likes

I tried this solution, I can delete replays but the constant patching loop still persists.

1 Like