Keyboard language switching off when turning on the game

I have a problem with Heroes of the Storm always switching off my keyboard language. As I live in Slovakia I use Slovakian keyboard and Slovak language on the computer and somethimes have to switch to the English (US) one. But everytime I launch the game the option on the bottom right disapears and I can’t do it anymore. It was happening with my windows 7 and is also happening with windows 10 now after I upgraded it and launched the game. It doesn’t matter that much when I play the game but after I quit the game I can’t turn it back on and I am stuck with one keyboard language until I restart the PC. Is there anything I can do about it?

Hey, DrDenson! It’s a bit odd that it doesn’t allow the language to be changed until restarting the system. Would you happen to have any hotkeys/shortcuts set to switch to language within Windows?

Yes, Left Shift + Left Alt does that but sadly even that doesn’t work after turning on the game. The ability to change languages just completly disapears

Thanks, DrDenson! It looks like this has been an issue since Windows 7 and happens across Windows 8 and 10 as well. I’m not sure if we can provide much suggestions here with this seeming to be a Windows level issue. There’s been some workarounds for this problem that may be worth trying. This should copy the language settings to the lock screen and all system/new accounts.

  1. Search for Language Settings on Windows.
  2. Click on Administrative Language settings on the side or bottom bar.
  3. Click on Copy Settings.
  4. Check “Welcome screen and system accounts” and “New user accounts.”

This should also allow you to change the languages on the lock screen (Windows Key + L) instead of needing a reboot. Hopefully, this will keep the language hotkeys and bar after Heroes of the Storm is open. If it does continue, you may have better luck with contacting Microsoft about this issue for further troubleshooting.

Hello, i have the same issue and it is only when i’m playing HOTS. Don’t have this problem with the other games. I test what you have showed but doesn’t work. I ask Microsoft Support for that and they told me this might be problem from the current game. I’m on windows 11.